WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#10697 closed defect (bug) (worksforme)

Write error for image uploading in 2.8.x

Reported by: ws5f3dj7 Owned by:
Milestone: Priority: high
Severity: major Version: 2.8.4
Component: Upload Keywords: image upload, image upload error
Focuses: Cc:

Description

As of the latest release of Wordpress 2.8.x various users of mine are encountering the following error:

"Unable to create directory /home/d363f86b/public_html/mamawize/wp-content/uploads/2009/08. Is its parent directory writable by the server?"

I've CHMOD 777 the directory and still maintain the error.

Change History (2)

comment:1 dd325 years ago

Is /uploads/, /uploads/2009/ and /uploads/2009/08/ all chmod 777? I'm thinking it might be one of those..

The issue is, That is_writable() is returning false in PHP, why it is returning false, is because PHP doesnt think it can write to the filesystem, Which is usually because of one of those above directories not being writable..

comment:2 miqrogroove4 years ago

  • Milestone Unassigned deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This is a tech support issue. Please visit the support forums. Re-open this ticket if you can confirm a problem in the WordPress code. Enjoy :)

Note: See TracTickets for help on using tickets.