WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#10747 closed defect (bug) (duplicate)

comment_agent field is too small

Reported by: itzik770 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.4
Component: Comments Keywords: needs-patch
Focuses: Cc:

Description

The comment_agent field in comments table is too small (255).

This causes an error if user agent field is larger than 255 - the comment is not inserted, and no message is displayed.
making this field 500 length fixed this problem

Change History (7)

comment:1 dd325 years ago

  • Component changed from General to Comments
  • Keywords dev-feedback added; comments removed

See #10389 - Truncate the field in order to prevent errors (not inserting).

Not sure increasing the length would be advisable however..

dev-feedback pending review of increasing the length or not. (If meta comes in, Storing such items in commentmeta would be better suited IMO)

comment:2 scribu5 years ago

Should wait for #2659.

comment:3 brianwhite5 years ago

I am not sure that this can wait given the coming release of Windows 7 next month. After I upgraded from windows Vista to Windows 7 I discovered that my user agent was too long. Further investigation revealed that many installations of Internet Explorer on computers that have been in use for a period of time and have multiple versions of the .NET CLR, etc. installed have user agent strings which exceed 255 when the Windows 7 specific strings were added after the upgrade. (The user agent sting is shorter and not problematical in fresh installations of Windows 7.) The likely hood of this happening becomes even greater with the introduction of tools like the Google Chrome Frame which add to the user agent string.

comment:4 scribu5 years ago

  • Keywords needs-patch added; dev-feedback removed

The best solution would be to move it to the new commentmeta table.

comment:5 scribu5 years ago

  • Milestone changed from 2.8.5 to 2.9

comment:7 dd324 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #10389 and #10856

Note: See TracTickets for help on using tickets.