WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#1075 closed defect (bug) (fixed)

Scheduled Entry Shows Wrong Time

Reported by: JPigford Owned by: ryan
Milestone: Priority: normal
Severity: minor Version:
Component: Administration Keywords:
Focuses: Cc:

Description

I set an article's timestamp to 10:00 (which right at this moment would be in 15 minutes). But on Dashboard it says it is scheduled for 6 hours from now.

It appears like it's taking the timestamp I set and saying that I told it to show at 10:00PM UTC time but the rest of the timestamps on other posts in the pasts are showing correct times and the "Output:" under "Date and Time" on the options page under "Default time format" are showing the correct time.

Attachments (1)

strtotime_gmt.diff (750 bytes) - added by JPigford 9 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 JPigford9 years ago

  • Patch set to No

comment:2 JPigford9 years ago

As an update. The post ended up posting at the correct time of 10:00AM despite Dashboard saying it would post in 6 hours. The issue is still there of it displaying the wrong time until it posts.

comment:3 sethkinast9 years ago

Seems just like 783. Should have been fixed already? :-/

comment:4 cavemonkey509 years ago

I can confirm this also. It appears it was not fixed.

comment:5 saadiq9 years ago

Additional confirmation here. It's purely cosmetic, however. The admin page seems to not take into consideration the time zone of the blog.

comment:6 MC_incubus9 years ago

My patch fixes it... try it out.

comment:7 MC_incubus9 years ago

  • Owner changed from anonymous to rboren
  • Status changed from new to assigned

comment:8 ryan9 years ago

I think strtotime is the culprit. Try the strtotime_gmt.diff patch.

comment:9 MC_incubus9 years ago

Yep Ryan, tested your diff and it works.

comment:10 ryan9 years ago

  • fixed_in_version set to 1.5.1
  • Resolution changed from 10 to 20
  • Status changed from assigned to closed

JPigford9 years ago

Note: See TracTickets for help on using tickets.