WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#10756 closed enhancement (fixed)

Improve POT file generator

Reported by: sirzooro Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

Please implement following enhancements for POT file generator:

  • use UTF-8 enconfig. Now it removes all non-ascii characters, at least in author's name (you can check this with my plugins);
  • read plugin name and put it in Project-Id-Version header (maybe version too);
  • set charset in Content-Type header to UTF-8.

Change History (3)

comment:1 nbachiyski4 years ago

  • Owner changed from ryan to nbachiyski
  • Status changed from new to accepted

comment:2 nbachiyski4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

All done.

The problem with author's name was caused by escapeshellarg(), which trims non-ASCII characters if the system locale encoding isn't UTF-8.

I also made the code, which set the project name and versions not depend on newer version of xgettext.

comment:3 scribu4 years ago

  • Milestone Unassigned deleted
Note: See TracTickets for help on using tickets.