WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#10808 closed defect (bug) (fixed)

Adding tag within DEBUG defined as true returns error.

Reported by: prettyboymp Owned by: westi
Milestone: 2.9 Priority: normal
Severity: trivial Version: 2.8.4
Component: Warnings/Notices Keywords: has-patch
Focuses: Cc:

Description

With DEBUG set to true, the edit tags page returns an error when adding an error. This is caused by the check_ajax_referer function checking for the value of '_ajax_nonce' without first checking that it is set.

Attachments (1)

check-ajax-referer.patch (481 bytes) - added by prettyboymp 5 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 scribu5 years ago

  • Milestone changed from Unassigned to 2.9
  • Severity changed from normal to trivial

You mean it's causing a warning, right?

comment:2 scribu5 years ago

  • Component changed from General to Warnings/Notices
  • Owner set to westi

comment:3 westi5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [11951]) Fix notice when adding tag from the Post Tags page. Fixes #10808 props prettyboymp.

Note: See TracTickets for help on using tickets.