WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10830 closed defect (bug) (fixed)

Import of WXR Larger than Maximum Size should give meaningful error message

Reported by: lloydbudd Owned by: westi
Milestone: 2.9 Priority: low
Severity: minor Version: 2.9
Component: Import Keywords: wxr, import, error messages,
Focuses: Cc:

Description

Import of WXR Larger than Maximum Size should give meaningful error message

ENV: wp trunk r11959 (2.9-rare)

ACTUAL RESULT

Notice: Undefined offset: 4 in /Library/WebServer/Documents/wp/trunk/wp-includes/functions.php on line 2410

Are you sure you want to do this?

Please try again.

ADDITIONAL DETAILS

The error log shows:

[22-Sep-2009 15:45:06] PHP Warning:  POST Content-Length of 130860924 bytes exceeds the limit of 8388608 bytes in Unknown on line 0
[22-Sep-2009 15:45:07] PHP Notice:  Undefined offset:  4 in /Library/WebServer/Documents/wp/trunk/wp-includes/functions.php on line 2410

Change History (5)

comment:1 westi5 years ago

  • Owner set to westi
  • Status changed from new to accepted

Looking at this - Caused by post_max_size being smaller than upload_max_filesize in php.ini

comment:2 automattor5 years ago

(In [11961]) Fix notice in wp_explain_nonce when the supplied action has no extra text. See #10830.

comment:3 westi5 years ago

(In [11962]) Move the nonce on the import upload form to the action url so it always arrives even if the post data exceeds post_max_size. Also add some phpdoc. See #10830.

comment:4 westi5 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [11963]) Handle the file upload case on import when post_max_size is smaller than upload_max_filesize and no POST data arrives at all. Fixes #10830.

comment:5 westi5 years ago

  • Milestone changed from Future Release to 2.9
Note: See TracTickets for help on using tickets.