WordPress.org

Make WordPress Core

Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#109 closed defect (bug) (invalid)

import-mt fatal error

Reported by: anonymousbugger Owned by: matt
Milestone: Priority: normal
Severity: major Version: 1.2
Component: General Keywords:
Focuses: Cc:

Description

Trying to import my (rather large, 2Mb flatfile) MT blog. Get this error message (yuck):

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 89 bytes) in /home/swissblogs/www/blog/wp-admin/import-mt.php on line 66

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 21 bytes) in Unknown on line 0

Change History (5)

#2 @2fargon
17 years ago

You might want to try splitting the file into file sof sixe < ~800Kb and importing the entries. The size restriction and the memory restriction is due to your server, and this problem has be recorded on the support forums before.

#3 @coffee2code
17 years ago

Does your server happen to be running FreeBSD?

I've been able to reproduce the above problem when attempting to import an MT-exported blog on a FreeBSD server. But as I discovered at <a href="http://wordpress.org/support/6/5553">this support thread</a>, the problem seems to be with FreeBSD and PHP. Namely, to resolve this, you have to edit php.ini and temporarily change this line:

memory_limit = 8M ; Maximum amount of memory a script may consume (8MB)

to:

memory_limit = 128M ; Maximum amount of memory a script may consume (8MB)

Also, on a later import, when I forgot to change that setting, I didn't get the "Fatal error" message mentioned above; I just got a blank page.

Not sure when this error gets triggered by a certain sized import file, or if it is always the case for an import under FreeBSD. For reference, the two blogs I imported were 1.2 and 1.6 MB import.txt files.

Ah, <a href="http://wordpress.org/support/2/7547">here's</a> another support thread with more people addressing the issue. There another suggestion is to split up the import file into <800kb chunks and import them separately.

#4 @matt
17 years ago

  • Owner changed from anonymous to matt
  • Resolution changed from 10 to 70
  • Status changed from new to closed

That's a host issue, basically saying that it ran of memory while processing the import. Try breaking up the file into two or there smaller files.

Note: See TracTickets for help on using tickets.