WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#10909 closed defect (bug) (wontfix)

wrong taxonomy structure

Reported by: thomask Owned by: filosofo
Milestone: Priority: normal
Severity: normal Version: 2.8.4
Component: Taxonomy Keywords: taxonomy
Focuses: Cc:

Description

IMHO there is an logic problem with taxonomy:

category (tag) name is defined in wp_terms table

category (tag) slug is defined in wp_terms table, but

category (tag) description is defined in wp_term_taxonomy table

this is IMHO problem in logic, i do not see any reason for spliting it in different tables and it can be problem for some future needs e.g. if someone (as me now) would need to have more parents for one category.
It would be only logic if it would be possible to define one term as tag AND as category AND as link_category with one name but with different descriptions (but i do not see a point of such need)

Change History (2)

comment:1 @dd326 years ago

I'm pretty sure the Description field is not designed for describing Terms, Rather, Its the description of a Taxonomy.

But you are right... It looks like the field is in a odd location for it, and instead, Appears to describe a Taxonomy-Term relationship instead.

However, I do not think the WordPress taxonomy system was designed for Term in multiple Taxonomies..

comment:2 @nacin5 years ago

  • Milestone Unassigned deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.