WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 12 months ago

#10941 closed enhancement (fixed)

Update and improve Features page of wordpress.org

Reported by: demetris Owned by: matt
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

As discussed in the IRC dev meeting of 8 October 2009 (no official log available; I can post the relevant part if anyone needs it), I started a Codex draft page to work on this:

http://codex.wordpress.org/User:Demetris/Features

Currently the Codex page does not have much copy, but focuses on ideas and thoughts about content and form. All input is appreciated!

Change History (10)

comment:1 jeffr04 years ago

If I had an idea for what to put into a section, would you like me to simply edit the Codex page and add in my idea or how do you want to go about the collaboration?

comment:2 janeforshort4 years ago

  • Milestone changed from 2.9 to Future Release
  • Type changed from defect (bug) to enhancement

Punting b/c this is not tied to a release cycle.

comment:3 matt4 years ago

  • Owner changed from ryan to matt
  • Status changed from new to assigned

When this page is more ready let me know and we'll get the WP.org one updated. It would be cool to do a layout like WP.com:

http://en.wordpress.com/features/

comment:4 demetris4 years ago

  • Cc dkikizas@… added

Argh! I have not received notifications for any of the comments on this ticket even though I opened it! Sometimes I cannot understand how Trac works. :-|

Sorry, all, for my silence!

@jeffr0

I think Trac—this ticket— or maybe a document in Etherpad would be better for collaboration. I don’t like MediaWiki very much for collaborative work.

@matt

I’ll start working on it again after the weekend. I agree about the wp.com layout. It’s very attractive — by comparison, the wp.org page looks like its poor neglected half sibling. :-D

comment:5 matt4 years ago

If you can help out on the content I'm happy to coordinate making it pretty.

comment:6 hakre4 years ago

So are changes on the codex page now welcome or not? I think if changes were welcome, you might get some feedback there. Or at least propose a discussion page in codex where everybody can contribute. From quick shots to larger parts.

comment:7 hakre4 years ago

  • Keywords reporter-feedback added

comment:8 ocean903 years ago

  • Keywords reporter-feedback removed
  • Milestone changed from Future Release to WordPress.org

comment:9 willmot12 months ago

  • Keywords close added

The features page was recently updated by @raggedrobins, do those changes cover what was intended with this ticket? Can it be closed?

comment:10 SergeyBiryukov12 months ago

  • Keywords close removed
  • Resolution set to fixed
  • Status changed from assigned to closed

Related: #23796

Note: See TracTickets for help on using tickets.