WordPress.org

Make WordPress Core

Opened 5 years ago

Last modified 23 months ago

#10947 new defect (bug)

Problem on import <embed> codes on mt.php script

Reported by: edgabaldi Owned by: Edgar Gabaldi
Milestone: WordPress.org Priority: normal
Severity: normal Version: 2.8.4
Component: Import Keywords:
Focuses: multisite Cc:

Description

I'm having trouble making the import of a file exported by CMS Movable Type.

All posts, categories, comments, users are imported correctly. The problem is that there are blocks of code in posts with the tag <embed> that are not being imported.

Change History (7)

comment:1 sivel5 years ago

  • Component changed from General to Import
  • Priority changed from high to normal

comment:2 edgabaldi5 years ago

i forgot to say that am working on WP-mu.

Testing a import with WP(mono user) the importation work perfectly.

comment:3 ryan5 years ago

WPMU does not allow users to import embeds. That would be a security hole. I think a site admin would have to do it.

comment:4 edgabaldi5 years ago

am logged as admin site, still does not work.

comment:5 r-a-y4 years ago

I can confirm what Edgar has written.

Tried to import posts with embed, iframe and embedded CSS with the Wordpress importer.

It stripped them from the post. I'm a site admin and I have the Unfiltered MU plugin installed as well.

comment:6 nacin4 years ago

  • Keywords multisite added; mt import problem removed
  • Milestone changed from Unassigned to Future Release

Unfiltered MU doesn't affect site (now super) admins.

comment:7 SergeyBiryukov23 months ago

  • Milestone changed from Future Release to WordPress.org
Note: See TracTickets for help on using tickets.