WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#10951 closed defect (bug) (duplicate)

backend form fields not readable for systems with dark themes, no text colour defined

Reported by: cocoknight5 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: UI Keywords:
Focuses: Cc:

Description

Most fields in the backend don't have background color and text color defined, leaving it to the system to decide the colors.

The title fields for pages and posts however have the background color set to white, but the text color is set by the system configuration. For people who are using a dark theme on their system, with white or almost white text, this means that the title field will display white text on white background, making the text unreadable.

There are two possible solutions for this: Either remove the background color or specifically define a text color.

Change History (7)

comment:1 scribu5 years ago

  • Component changed from Accessibility to UI
  • Milestone changed from Unassigned to Future Release

comment:2 cocoknight54 years ago

It looks like this issue's gotten worse, since 2.9 I believe. Most fields' text in the backend are now not visible for people using white font colour on their system theme. In fact, as far as I can tell the rich text editor's field is the only one to show black text on white background instead of white text on white background. So there's probably a general CSS rule somewhere that defines the background of all form fields. There, a definition for the text colour should be added.

comment:3 cocoknight54 years ago

  • Cc cocoknight5 added

comment:4 cocoknight54 years ago

  • Summary changed from problem with colors for post and page title fields in backend to backend form fields not readable for systems with dark themes, no text colour defined

comment:5 johnbillion3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as dupe of 11645 which has more discussion

comment:7 nacin3 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.