WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

Last modified 4 months ago

#10982 closed defect (bug) (wontfix)

Category hierarchy in list of categories do not display correctly when editing a post

Reported by: dj-wp Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: General Keywords:
Focuses: Cc:

Description

When editing a post, the category hierarchy in the list of categories can display incorrectly.

How to reproduce

  1. Create categories in a hierarchical way as shown in Figure 1.
  1. Create a post and check the same categories that are checked in Figure 1.
  1. Save and wait for reload. Look at the categories, they should show up like in Figure 2. Hierarchy is broken, and so is order.

This is tested on a fresh install of WordPress 2.8.4, no plugins installed nor activated. It gets irritating when you have a huge list of nested categories.

Attachments (2)

Figure-1.png (6.2 KB) - added by dj-wp 5 years ago.
Figure 1
Figure-2.png (6.1 KB) - added by dj-wp 5 years ago.
Figure 2

Download all attachments as: .zip

Change History (29)

@dj-wp5 years ago

Figure 1

@dj-wp5 years ago

Figure 2

comment:1 @dj-wp5 years ago

  • Summary changed from Category hierarchy in list of categories do not display correctly when editinga to Category hierarchy in list of categories do not display correctly when editing a post

comment:2 follow-up: @scribu5 years ago

  • Milestone Unassigned deleted
  • Resolution set to invalid
  • Status changed from new to closed

That's a feature: move checked categories to the top, for easier scanning. Useful for when you have a lot of categories.

comment:4 in reply to: ↑ 2 @dj-wp5 years ago

Replying to scribu:

That's a feature: move checked categories to the top, for easier scanning. Useful for when you have a lot of categories.

Okay, so this is an intended behavior... Calling this an enhancement is highly subjective in my opinion because according to the comments of that ticket (#7000) I'm not the only one doesn't agree with it. I understand that this will please some, but I also believe that it is annoying to others. Hopefully we will get to see a better solution in the future.

comment:5 follow-up: @vteixeira5 years ago

  • Milestone set to 2.9.3
  • Resolution invalid deleted
  • Status changed from closed to reopened

This is a known bug.

comment:6 @scribu5 years ago

  • Milestone changed from 2.9.3 to Future Release

You can use this plugin:

Category Checklist Tree

comment:7 @archon8105 years ago

  • Cc admin@… added

+1 to fix this in core from me.

For reference, #12312 that I filed earlier was marked as duplicate of this ticket.

comment:8 in reply to: ↑ 5 ; follow-up: @nacin5 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

Replying to vteixeira:

This is a known bug.

Just to clarify, this is done by design. If you have a lot of categories, it is very convenient. The less categories you have, the more likely you probably are to think it's a bug.

Closing as invalid, but also cross-referencing #3130.

comment:9 in reply to: ↑ 8 @vteixeira5 years ago

  • Milestone set to 3.0
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 2.8.4 to 2.9.2

Replying to nacin:

Replying to vteixeira:

This is a known bug.

Just to clarify, this is done by design. If you have a lot of categories, it is very convenient. The less categories you have, the more likely you probably are to think it's a bug.

Closing as invalid, but also cross-referencing #3130.

I think I must write what I think and why this must be reopened as a bug:

If you want to put the post assigned categories at the top of the list this is OK, but it should never break the hierarchy, never.

Breaking the hierarchy confuses the user and makes it almost impossible in some circumstances to find the proper category to select.

And contradicting what you said, when I have lots of categories this is even worst. If the post is assigned to the parent category and one child, the other child categories will appear at the bottom of the categories list totally isolated from the parent category making it very difficult to find them and to know that those categories are child of the one our post is assigned to. See the problem?

I have a test case (a site that I'm building right now) that beautifully illustrates the problem on the worst scenario: I have lots of child categories with the same names, ex: Parent1 -> national, international; Parent2 -> national, international; Parent3 -> national, international;
So I have different Parent categories names but the same child category names for each parent category.
How am I supposed to find the correct child category to apply for my parent category?

Usability bug.

What really confuses me is that on the post quick edit the categories are OK (it's just not indented), the problem is just on the Edit post screen.

Just something I want to add: there are two tabs on the categories box on the edit post page -> All Categories and Most Used.
If you select the Most Used tab it will already show the assigned categories at the top without hierarchy, so why should the All Categories tab break the hierarchy to show the assigned categories at the top? It's already done on the other tab!

Let's keep it the way it is intended to be: a list of categories and subcategories - respecting the hierarchy, please.

This is a real usability problem.

comment:10 follow-up: @nacin5 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:11 in reply to: ↑ 10 @vteixeira5 years ago

  • Milestone set to Future Release
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Replying to nacin:

#3130

I posted on #3130 too. But the problem here is that the #3130 ticket is for enhancing the categories view with some sort of folding stuff.

And this ticket is about a bug, as I wrote above.

So it's not duplicated.

Let's reopen again. It really needs fixing.

And it should not be that difficult as there's already a plugin fixing it.

comment:12 follow-up: @jane5 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

It's not a bug, it's a usability issue. It behaves the way it was originally developed to behave. This ticket is invalid as a bug report, because what you are reporting is the intended behavior. Lobbying to change the intended behavior is not what a bug ticket is for. If you want to lobby for the behavioral change, please open a thread at http://wordpress.org/extend/ideas. Do not reopen this trac ticket, please.

comment:13 @scribu5 years ago

  • Milestone Future Release deleted

comment:15 in reply to: ↑ 12 @hakre5 years ago

Replying to jane:

It's not a bug, it's a usability issue. It behaves the way it was originally developed to behave. This ticket is invalid as a bug report, because what you are reporting is the intended behavior. Lobbying to change the intended behavior is not what a bug ticket is for. If you want to lobby for the behavioral change, please open a thread at http://wordpress.org/extend/ideas. Do not reopen this trac ticket, please.

Oh, it's a very long time (some might say overdue) "change of the intended behavior": #3130

And just for the log: Everything is intended, because it has been written in code. Remember that next time, then you do not need to stress the term "usability" for that.

comment:16 @scribu5 years ago

Marked #14723 and #14916 as duplicates of this.

comment:17 @scribu5 years ago

I don't see why usability issues should be sent off to the ideas forum, while all the rest can be discussed on trac.

comment:18 @aaroncampbell5 years ago

  • Cc aaroncampbell added

comment:19 @porridgebear3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

+1 to change the default strategy of WP here.

This has been highly confusing for our users. In the case of many categories, some with the same names but in different branches of a hierarchical tree, this "undoing" of the true hierarchy does not allow users to identify the correct category to use. The problem is even worse if you check the top level category but no children. All of a sudden the parent and all children are listed in one list.

I can't even begin to see a use for this, even the suggested "it's easier to see them at the top" is not compelling. In my view to support both you could break the Category box into 2 tabs - Tab 1, the actual tree and Tab 2 - Used categories. That is the best of both worlds.

Right now it is horrible to work with.

comment:20 @solarissmoke3 years ago

Marked #20054 as duplicate.

comment:21 @SergeyBiryukov3 years ago

  • Milestone set to Awaiting Review

comment:22 @SergeyBiryukov3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

Introducing a filter in #20054 seems like the way to go.

comment:23 @olleicua3 years ago

  • Cc olleicua@… added

It's possible to move things to the top without breaking the hierarchy, simply move all parents and children of a category to the top if it is checked. I'm having trouble believing that it was in fact the intended behavior for the hierarchy to be broken and not simply an oversight. Whether you call that a bug is pretty semantic.

If this was in fact the intended behavior then can some one please explain why it was chosen over the method I just described. As it is I actually thought I had ruined my taxonomy structure.

Last edited 3 years ago by olleicua (previous) (diff)

comment:24 @helen14 months ago

#16475 was marked as a duplicate.

comment:25 @SergeyBiryukov6 months ago

#29871 was marked as a duplicate.

comment:26 @SergeyBiryukov4 months ago

#29871 was marked as a duplicate.

comment:27 @SergeyBiryukov4 months ago

#30721 was marked as a duplicate.

Note: See TracTickets for help on using tickets.