WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 4 years ago

#10988 reopened defect (bug)

http://domain.tld/keyword searches media library for matching items when logged in

Reported by: squirrelpimp Owned by: ryan
Milestone: Future Release Priority: normal
Severity: normal Version: 2.8.4
Component: Permalinks Keywords:
Focuses: Cc:

Description

On my site i have a file in the media library called else.jpg. If I access http://lekv.de/else I get the expected 404. If I'm logged in in the backend however, I get redirected to the media item page of else.jpg (where I could download it). Also pretty permalinks have to be enabled using .htaccess files.

To reproduce, you have to create a media library item with a simple name, say else.jpg and upload it, using "else" as description in every form field. Then simply enable pretty urls, login into the backend and access http://domain.tld/else.

I hope, this is comprehensible.

My version is 2.8.4 DE-Edition.

Change History (4)

comment:1 hakre4 years ago

  • Milestone changed from Unassigned to 2.9

So would you rate this as a bug or as a feature?

From what you explain it looks a bit too me that the cause of this error is somewhere down in the WP_Query class and the (undocumented) algorythm to decide what an URI stands for. Have you done something to find out what the cause of the reported behaviour is?

comment:2 nacin4 years ago

  • Keywords reporter-feedback added
  • Milestone changed from 2.9 to Future Release

comment:3 johnbillion4 years ago

  • Keywords reporter-feedback removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as dupe of #12634 which is a more active ticket.

comment:4 nacin4 years ago

  • Milestone set to Future Release
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Not convinced this is a duplicate quite yet. In #12634 we're having trouble duplicating it.

Note: See TracTickets for help on using tickets.