WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11001 closed defect (bug) (fixed)

OperationalError: database is locked

Reported by: scribu Owned by: ryan
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

How to Reproduce

While doing a GET operation on /login, Trac issued an internal error.

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20091020 Ubuntu/9.10 (karmic) Firefox/3.5.3

System Information

Trac 0.11.4
Python 2.4.4 (#1, Oct 22 2008, 20:17:05)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools 0.6c9
SQLite 3.3.8
pysqlite 2.3.2
Genshi 0.5
Pygments 0.10
Subversion 1.4.2 (r22196)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 435, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/auth.py", line 101, in process_request
    self._do_login(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/auth.py", line 140, in _do_login
    "VALUES (%s, %s, %s, %s)", (cookie, remote_user,
  File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/db/sqlite_backend.py", line 58, in execute
    args or [])
  File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked


Change History (6)

comment:1 dd324 years ago

  • Component changed from General to WordPress.org
  • Owner set to ryan

Happens pretty often now and then... I often end up hitting back and resubmitting it and it flows through.

comment:2 mdawaffe4 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Talked to Barry. Caused by using old SQLite trac backend. Will upgrade or switch to MySQL backend soonish.

Despite the future fix, closing as wontfix.

comment:3 barry4 years ago

Upgraded Trac to 0.11.6 which is supposed to fix this error:

http://trac.edgewall.org/browser/tags/trac-0.11.6/RELEASE

"Fixed the "database is locked" issue with SQLite (#3446, #8468)."

comment:4 barry4 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:5 barry4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 westi4 years ago

  • Milestone changed from Unassigned to WordPress.org site bugs
Note: See TracTickets for help on using tickets.