WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#11022 closed defect (bug) (duplicate)

Post Revisions List Full of Nonsense

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: major Version: 2.6
Component: Revisions Keywords: needs-patch
Focuses: Cc:
PR Number:

Description

Ever sense versioning was introduced into WP, the author names and dates listed in the revisions list have been wrong. It would be so nice to get this working.

Change History (12)

#1 @dd32
10 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

See #10004: defect (bug): Auto saved page revisions show the wrong user (closed: fixed)

#2 @miqrogroove
10 years ago

  • Milestone set to 3.0
  • Resolution duplicate deleted
  • Status changed from closed to reopened

2.9.2 is still showing the wrong name on revisions.

Example:

user1 saves a post 6 times, so there are 5 old revisions in the list.

user2 comes along and saves changes 3 times. The newest revision by user1 is saved with user2 as the author.

#3 @Viper007Bond
10 years ago

Can you try to reproduce this using trunk instead of 2.9.2 please?

#4 @miqrogroove
10 years ago

Note to self: see #12802 when testing.

#6 @miqrogroove
10 years ago

Steps to reproduce:

  1. Create/Find a post with one or more revisions by the original author. Note the date of the post and revisions.
  1. Switch to a user other than the original author (Editor or Admin).
  1. Save a new draft of that post.

Expected result: The existing post should become the most recent revision, by the original author.

Actual result: The revisions list looks like this:

17 March, 2010 @ 11:52 by user1
17 March, 2010 @ 11:37 by admin

.. where the most recent revision by admin was 17 March @ 11:52, and the most recent revision by user1 was 4 April.

If the latest revision had been an Autosave, the list looks like this:

10 March, 2010 @ 19:39 [Autosave] by miqrogroove
10 March, 2010 @ 19:36 by testperson
10 March, 2010 @ 19:36 by miqrogroove

.. where the most recent revision by miqrogroove was 10 March @ 19:39, and the most recent revision by testperson was 4 April.

I tested the post editor on 2.9.2 and 3.0-alpha. I tested neither Quick Edit nor 3.0-beta, and I have no reason to believe this behavior has changed since v2.6.

#7 @miqrogroove
10 years ago

I should elaborate on "Expected result". If the intention is to show the current draft as the most recent revision, that's perfectly fine with me. Showing the pre-save draft with the pre-save author is also fine. Showing the pre-save draft with the current author is wrong, and that's the meat of the issue. The revision system behaves as though its designer couldn't decide whether to show the current draft as a revision or not.

#8 @nacin
10 years ago

  • Keywords needs-patch added

Very tempting to move to future release pending patch, since it's been like this since 2.6. This affected by what was expressed as "expected" in #12515 at all?

#9 @miqrogroove
10 years ago

My guess is they are separate bugs.

#10 @ryan
10 years ago

  • Milestone changed from 3.0 to Future Release

#11 @dd32
9 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing as duplicate of #15130 fixed in 3.1

#12 @nacin
9 years ago

Actually, the better duplicate is probably #16215.

Note: See TracTickets for help on using tickets.