WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11025 closed defect (bug) (invalid)

changing permalinks settings deletes all content in htaccess

Reported by: k0rp0rate Owned by: ryan
Milestone: Priority: normal
Severity: major Version: 2.8.5
Component: Permalinks Keywords: permalinks, htaccess
Focuses: Cc:

Description

I.e:

If you go to Settings -> Permalinks, and change from 'custom structure' to 'default', WordPress completely deletes the content in the .htacces file, not only the content between # BEGIN WordPress and # END WordPress.

So if you have anything added by a plugin or manually by you below the # END WordPress outside of the WordPress added rules, ALL is deleted too.

You lost ALL .htaccess content :(

This's happening with 2.8.5 (not in version list to choose, sorry), I'm pretty sure of not having this problem in earlier versions.

Change History (4)

comment:1 westi4 years ago

  • Version changed from 2.8.4 to 2.8.5

comment:2 westi4 years ago

  • Keywords reporter-feedback added; permalinks htaccess removed

I can't reproduce this.

Could you supply an example .htaccess file that WordPress destroys in this manner?

Also what plugins are you using?

comment:3 k0rp0rate4 years ago

  • Keywords permalinks htaccess added; reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

So sorry, I found a permission problem on the server, that was the problem. The manual modifications never was writed really.

Sorry!

comment:4 scribu4 years ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.