WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#11044 closed defect (bug) (invalid)

Garbage data appears in img class

Reported by: schwartzman Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

  1. I post this in the HTML editor, or just let the visual editor generate it:
    [caption id="attachment_2801" align="alignright" width="300" caption="Photo by Lidal-K."]<img class="size-medium wp-image-2801" title="inflambreast_oct_09" src="http://www.wellwire.com/wp-content/uploads/2009/10/inflambreast_oct_09-300x250.jpg" alt="Photo by Lidal-K." width="300" height="250" />[/caption]
    
  1. I update the post.
  2. I switch to the visual editor, and make no changes.
  3. I switch back to the HTML editor, and this is what I see:
    [caption id="attachment_2801" align="alignright" width="300" caption="Photo by Lidal-K."]<img class="size-medium wp-image-2801 cyvbjwiiviooelcuridf cyvbjwiiviooelcuridf" title="inflambreast_oct_09" src="http://www.wellwire.com/wp-content/uploads/2009/10/inflambreast_oct_09-300x250.jpg" alt="Photo by Lidal-K." width="300" height="250" />[/caption]
    

Note the junk ("cyvbjwiiviooelcuridf") in the img class. Sometimes the string repeats three times, sometimes once. But you get the idea.

This is a live site, so unfortunately turning off all plugins and reverting to the default theme is not an option at this time.

This is my first ticket, so please accept my apologies if it is incomplete or poorly submitted.

Environment:
OS X 10.4.11, FF 3.5.3, WP 2.8.5

Change History (7)

comment:1 @schwartzman6 years ago

  • Cc mantle@… added
  • Severity changed from major to normal

Update:
Unable to reproduce the problem in any browser except Firefox.
In Firefox the extra gobbledygook shows up both in the HTML editor and in the compiled source. In other browsers, even while viewing the source of the same page at the same time as I'm seeing the unwanted data in Firefox, the extra stuff isn't present. Another string that's come up is: "yhvhzwisuplnnpaoktgy". I am stumped.

comment:2 @schwartzman6 years ago

  • Cc anthony@… added

comment:3 @azaozz6 years ago

  • Keywords reporter-feedback added

There's no code in WordPress that would add these strings. Looks like a Firefox addon that's misbehaving. You can try running FF in safe mode or create another profile and try to reproduce again.

comment:4 @schwartzman6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

It did all came down to a Firefox extension: AdBlock Plus, http://adblockplus.org/en/

Somehow it latched onto that one image and wouldn't let go. Whitelisting the site in ABP prefs solved the problem.

comment:5 @scribu6 years ago

  • Milestone Unassigned deleted

comment:6 @dd326 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 @dd326 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.