WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11065 closed defect (bug) (invalid)

"add an image" button in "upload/insert" menu in posting screen malfunction. Opens below footer of same page and is positioned out of reach to left off of screen

Reported by: JohnR123 Owned by:
Milestone: Priority: lowest
Severity: trivial Version: 2.8.5
Component: Upload Keywords: reporter-feedback
Focuses: Cc:

Description

When trying to insert image into post (edit or new) if I click on the "add image" button, it will open on the same page below the footer of the page and is offset in position so that most of it is out of reach (beyond the left border of page). It is supposed to open as a ghost over the current page.

If I try right click the button and open it in a new tab, the features are all there but when I then browse (browser uploader option) my local files and select an image, then hit "upload" I see the image and am presented with the usual options on size etc. I, then click "insert in post" but I get a blank white screen and nothing is inserted in the post (I have tried refreshing).

This occurs on three installations of version 2.8.5. Two of these installations are brand new (image upload has never worked on these) and were from separate downloads of the wordpress zip file. These new installations are running on my local apache2 server. The other installation is a live site on BlueHost servers. It is an established site that I have kept up with regular upgrades. I recently upgraded to version 2.8.5 and now this site exhibits the exact same behaviour as the two local sites.

The local sites are running the default theme with no content added and no new plugins have been uploaded and the default plugins have not been enabled.

My local computer is running Linux Ubuntu 9.04 and the latest FireFox for Ubuntu. I have the latest Java installed as well as Adobe Shockwave and the latest flash for Linux. I have enabled all Java advanced features. I have also tried to upload images to a post using another computer that runs Windows XP Pro. I tried using FireFox on that system as well as IE 8, and I get the same malfunctions exactly.

So in summary, I have this problem happenning on three 2.8.5 versions of WordPress two of which are brand new clean installs with no additions running on an apache2 server with the latest mysql and php5. The configuration is correct with the appropriate settings in php.ini as well. The other version 2.8.5 is an older site recently upgraded (hasn't worked since) and it runs on Bluehost's server. We (Bluehost and I) have checked the settings and inspected the database behaviour for problems, etc, and everything seems good at their end.

My file permissions on all sites are correct at 755 for directories and 644 for files. On the local served sites I have even tried maxing out the permissions with no success.

On the new installs I had to temporarily set the wp-content directory at a higher permission to auto-create uploads folders and sub-directories as no uploads folder came with either download of the WordPress zip. I also tried creating those folders manually just in case that would help. Also, the settings on Misc admin page is the correct path (wp-content/uploads).

3 different installs, 2 new and 1 upgrade, on 2 different servers, accessed by two different computers using different browsers cannot be a fluke problem. It needs to be looked at. I can't do anything with any of these sites until it is resolved.

Thank you very much for reading this and helping out.

Best,
John

Attachments (2)

Screenshot_plugin_install.png (159.7 KB) - added by JohnR123 6 years ago.
Screenshot_image_upload.png (108.4 KB) - added by JohnR123 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 @scribu6 years ago

  • Keywords reporter-feedback added; upload insert add image button removed

Try running a nightly build (using the WP Beta Tester plugin) and see if the problem persists.

comment:2 @JohnR1236 years ago

scribu,

I wouldn't want to run the latest beta of 2.9 on my live site in the hopes that it is fixed in that version. Too risky, and I want always to keep my local version the same as the live. Thanks but there has to be a reason for this problem in 2.8.5 and I'd like to solve it there rather than possibly carrying over any residual problems into another version where they may show up differently.

comment:3 @JohnR1236 years ago

  • Cc rocheleau@… added

This seems to be going nowhere so I have added attachments to this ticket.

They are two screen shots showing the window I am presented with when clicking the image upload button or when trying to install a new plugin using the automatic feature (just another upload problem).

As you can see, in both scenarios, the window opens up below the footer of the current page and is offset to the left so that you cannot access it. And even when you can access the links in the upload dialogue section, it will not work if you are inserting an image into a post. It will only work if you are uploading and installing a plugin, provided the links to click are within reach on the screen.

These screenshots are from a fresh install of 2.8.5 with no content added and no plugins enabled.

I am on hold until this is answered. Do I have to switch from WordPress to carry on with my web business?

comment:4 @scribu6 years ago

Minor versions like 2.8.5 are usually only for security patches. So this won't get fixed before WP 2.9 comes out anyway.

So why not just add a new test install with the nightly build and see if the problem is still there?

comment:5 follow-up: @JohnR1236 years ago

The only site I can add a beta-tester plugin to, would be one of the local versions but I cannot get upgraded on these after installing the plugin. It returns an error when trying to upgrade. This may be due to ftp not being set up for the local sites on the local server. I'm not sure how to set that up so...

The only site I can use the beta tester plugin and actually upgrade would be my live site, but how much of a risk is that? They explicitly warn against beta-testing on live sites.

This being the case, do I have to wait until WordPress 2.9 comes out in the hopes that it will solve this issue? Why would they not want to fix a problem in the current release if it stops people from using their sites? I don't know where to turn really, except to another CMS/blogging platform. I don't want to, but what are my options?

I was really hoping WordPress would look into this and fix it. I have read may 200 posts on this very problem. It obviously exists, and it certainly restricts free use of the system.

comment:6 in reply to: ↑ 5 @scribu6 years ago

Replying to JohnR123:

The only site I can add a beta-tester plugin to, would be one of the local versions but I cannot get upgraded on these after installing the plugin. It returns an error when trying to upgrade. This may be due to ftp not being set up for the local sites on the local server. I'm not sure how to set that up so...

You can download the nightly build manually:

http://wordpress.org/nightly-builds/wordpress-latest.zip

This being the case, do I have to wait until WordPress 2.9 comes out in the hopes that it will solve this issue? Why would they not want to fix a problem in the current release if it stops people from using their sites?

If WordPress had an infinite number of developers working on it around the clock, I'd agree with you. But since that is not the case, you can't expect the 4 commiters to fix every bug right away.

I was really hoping WordPress would look into this and fix it. I have read may 200 posts on this very problem. It obviously exists, and it certainly restricts free use of the system.

It would be useful if one of those posts contained a reliable way to reproduce the problem. If it does, please post it here.

comment:7 @JohnR1236 years ago

I understand what you are saying. I am just getting frustrated that I cannot use my site as normal for over two weeks. Unfortunately those posts I have read all point to solutions for some such as permissions, etc, that do not solve my issue.

I tried to download the nightly build manually through upgrade in tools, but the download, even though it said it would be the nightly build, was the 2,8.5 version. Using your link however I have successfully downloaded the 2.9 version. Thank you. I will set that up and see if the issues are resolved there.

I'll let you know by tomorrow morning hopefully. :-)

John

comment:8 @JohnR1236 years ago

Update:

Okay, I have downloaded the latest 2.9 build as per your link and installed it as a new site. Unfortunately this exhibits the same issues exactly as above.

I cannot understand this. I am sure that for most it works fine. Why on earth would 4 installations of two different versions on two different servers accessed by two different computers using different browsers, all have the same issue for me? That's a little long-winded but you get the point :-)

There must be something missing in this puzzle.

comment:9 @scribu6 years ago

It really is a mistery. :)

comment:10 @JohnR1236 years ago

  • Priority changed from high to lowest
  • Resolution set to invalid
  • Severity changed from major to trivial
  • Status changed from new to closed

Update -- close this:

I've just set this to "invalid." I hope that is the way to cancel any attention to this. It turns out that the cause of the problem was an entry in my .htaccess above the wordpress section. It was a recommended method (on a few sites) to stop browsers from seeing a directory list of wp-includes. It worked for that and redirected back to the home page, but I didn't realise that it was causing this malfunction in the image uploader. Removing those four lines from .htaccess fixed my problem.

I apologize for taking up space and time here.

comment:11 @scribu6 years ago

  • Milestone Unassigned deleted
Note: See TracTickets for help on using tickets.