Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#11080 closed defect (bug) (duplicate)

Category exporting problem resulting in duplicate categories when importing

Reported by: catahac Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Export Keywords: category, export, import, duplicate
Focuses: Cc:


Certain chain of action lead to having duplicate categories when importing a wordpress export.
The steps to reproduce:

  1. Create a Category but leave the slug to be auto-generated
  2. Add a new post and attach it to that category
  3. Change only the slug of the category
  4. Export
  5. Import
  6. You will see that your category has been duplicated.

I just tested this in 2 fresh installs and the issue occurs

Change History (3)

#1 @scribu
6 years ago

  • Version set to 2.9

Reproduced in trunk.

Got two categories:

Test Cat | test-cat | 0 posts <-- this shouldn't be here
Test Cat | test-cat-bla | 1 posts

#2 @janeforshort
6 years ago

  • Milestone changed from 2.9 to Future Release
  • Priority changed from high to normal
  • Severity changed from major to normal

Reported too late to make it into 2.9. Punting due to lack of patch.

#3 @scribu
6 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Marking as dup of #11354 since it has a patch already.

Note: See TracTickets for help on using tickets.