WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#11105 closed defect (bug) (invalid)

Transfer to a blank page

Reported by: omerosen Owned by:
Milestone: Priority: high
Severity: critical Version:
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

After every action that I do in my blog I am transferred to a blank page. For ex. when I preview edited changes in a post I get this page: http://mysite.com/wp-admin/post.php, instead of getting the post itself.
The same problem returns with all other action that I do. I also noticed that when I try to export the DB instead of getting a file I am transferred to a page with some of the posts in a mass page.

It started after installing a plugin called WP-cycle, but I am not 100% sure that it caused the problem as it is working perfectly when I use it on a local server.

Change History (15)

comment:1 @scribu6 years ago

  • Keywords reporter-feedback added; blank page removed

Add this line to wp-config.php:

define('WP_DEBUG', true);

Now instead of a blank page, you should get the actual error that's interrupting the redirect.

comment:2 @omerosen6 years ago

It did not work. I still get the blank page

comment:3 @scribu6 years ago

Try disabling all plugins and switching to the default theme and see if the problem persists.

I'm pretty sure it's not a problem with WordPress itself.

comment:4 @omerosen6 years ago

I did it and the problem remained. Can it be a file that got corrupted after I installed a plugin?

comment:5 @scribu6 years ago

It's possible.

Try downloading a nigtly build and installing it on your server, separately.

Then we can be absolutely sure it's not related to a plugin.

comment:6 @omerosen6 years ago

What is that? A blog theme?

comment:7 @scribu6 years ago

No, it's the latest version of WordPress: 2.9-rare.

comment:8 @omerosen6 years ago

Do you think I should upload all my WP files and run over the files that are there now?

comment:9 follow-up: @scribu6 years ago

No, you should put them in a new folder.

comment:10 in reply to: ↑ 9 @omerosen6 years ago

Replying to scribu:

No, you should put them in a new folder.

I dont mean these files, I mean WP file of the same version being uploaded to the same directories. Would it cause any damage?

comment:11 follow-up: @strider726 years ago

Delete the WordPress folder. Create a fresh one from the WP download. (In other words, *don't* just overwrite the files that are there. Start fresh.)

comment:12 in reply to: ↑ 11 @omerosen6 years ago

Replying to strider72:

Delete the WordPress folder. Create a fresh one from the WP download. (In other words, *don't* just overwrite the files that are there. Start fresh.)

but what will happen to my DB (posts,pages, media)?

comment:13 follow-up: @scribu6 years ago

You can change the DB prefix in wp-config.php so that the new installation creates separate tables.

comment:14 in reply to: ↑ 13 @omerosen6 years ago

Replying to scribu:

You can change the DB prefix in wp-config.php so that the new installation creates separate tables.

I uploaded the files of the same version over the existing files and I the problem is still there...
I found this forum discussion http://wordpress.org/support/topic/233756 and I guess the solution might be downgrading.

comment:15 @nacin5 years ago

  • Milestone Unassigned deleted
  • Resolution set to invalid
  • Status changed from new to closed

This seems to be a support question, not a bug in WordPress. Closing pending feedback.

Note: See TracTickets for help on using tickets.