WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#11127 closed enhancement (wontfix)

Improve plugin compatibility check

Reported by: sirzooro Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 2.8.5
Component: WordPress.org site Keywords: needs-patch
Focuses: Cc:

Description (last modified by dd32)

When you install new plugin via WordPress backed, it checks if 'Compatible up to' version specified in plugin's readme.txt file is big enough. If not, WP displays warning 'This plugin has not been tested with your current version of WordPress.'.

In general such check is a good idea, but it needs improvement. When WP Team finishes new major WP release, such message is OK (e.g. when someone will try to install plugin tested up to 2.8.5 on 2.9), because API or other internal details may change. But when we have security or bugfix release, API usually stays the same, so most plugins do not require update.

Unfortunately current warning message is misleading for beginners, and some of them posts questions like 'Does plugin X works with WP 2.8.5, because WP says it was not tested with this version?'.

I am sure there are many more ones who will decide to not install plugin and find another one, which will be marked as compatible.

In order to avoid such questions plugin's author have to release new plugin version with updated 'Tested up to' tag. This takes time, especially if someone (like me) has many plugins.

Therefore I suggest to skip this warning in case of version mismatch introduced by security/bugfix WP releases (e.g. 2.8.5 - 2.8.6, or 2.8 - 2.8.6).

(edit by dd32: added some paragraphs to make it readable)

Change History (6)

comment:1 dd325 years ago

  • Component changed from Plugins to XML-RPC
  • Owner changed from westi to josephscott

"Tested" was chosen instead of "Not Compatible" for that exact reason, it leaves it open.

Some plugin authors set the compatible version to 2.8.9. That solves the 2.8.x compatibility issues.

Perhaps the point release should be striped from compatible.. and just leave that for required.

BUT in the same light, With security changes in point releases, some plugins will break, therefor, setting it to compatible-with-all-point-releases has the downside of being incorrect for some plugins.

WordPress.org milestone: Its an website/API issue.

comment:2 dd325 years ago

  • Component changed from XML-RPC to WordPress.org
  • Owner changed from josephscott to ryan

comment:3 dd325 years ago

  • Description modified (diff)

comment:4 sirzooro5 years ago

Thanks for the tip regarding setting compatible version to 2.8.9 - I will use it in my plugins.

comment:5 ryan5 years ago

  • Milestone 2.9 deleted

comment:6 scribu5 years ago

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.