Improve plugin compatibility check
|Reported by:||sirzooro||Owned by:||ryan|
Description (last modified by dd32)
When you install new plugin via WordPress backed, it checks if 'Compatible up to' version specified in plugin's readme.txt file is big enough. If not, WP displays warning 'This plugin has not been tested with your current version of WordPress.'.
In general such check is a good idea, but it needs improvement. When WP Team finishes new major WP release, such message is OK (e.g. when someone will try to install plugin tested up to 2.8.5 on 2.9), because API or other internal details may change. But when we have security or bugfix release, API usually stays the same, so most plugins do not require update.
Unfortunately current warning message is misleading for beginners, and some of them posts questions like 'Does plugin X works with WP 2.8.5, because WP says it was not tested with this version?'.
I am sure there are many more ones who will decide to not install plugin and find another one, which will be marked as compatible.
In order to avoid such questions plugin's author have to release new plugin version with updated 'Tested up to' tag. This takes time, especially if someone (like me) has many plugins.
Therefore I suggest to skip this warning in case of version mismatch introduced by security/bugfix WP releases (e.g. 2.8.5 - 2.8.6, or 2.8 - 2.8.6).
(edit by dd32: added some paragraphs to make it readable)
Change History (6)
- Component changed from Plugins to XML-RPC
- Owner changed from westi to josephscott
- Component changed from XML-RPC to WordPress.org
- Owner changed from josephscott to ryan