WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11141 closed enhancement (fixed)

Link missing

Reported by: F J Kaiser Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 2.9
Component: Users Keywords: has-patch commit
Focuses: Cc:

Description

when you request a new password and it get´s sent to your e-mail adress, then you get a new screen, confirming, that your message was successfully sent. But there´s no link back to the login screen.

thanks!

Attachments (1)

11141_wp-login.patch (785 bytes) - added by nacin 4 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 scribu4 years ago

  • Milestone changed from Unassigned to Future Release

There's a link in the email, but I guess one on that screen too wouldn't hurt.

comment:2 nacin4 years ago

  • Component changed from General to Users
  • Keywords has-patch added
  • Milestone changed from Future Release to 2.9
  • Type changed from feature request to defect (bug)
  • Version changed from 2.8.5 to 2.9

Patch attached and I'm reclassifying this as a defect in the UI flow.

Currently, the form doesn't show under two circumstances: 1) After you request the first e-mail, and 2) after you click the link in that e-mail, which triggers the second e-mail with your new random password. This patch removes both circumstances.

In the second case, the user is presented only with "Check your e-mail for your new password." It makes sense that a user might switch to their email, copy the password, and return to the form (wp-login.php?checkemail=newpass) in their browser. (Instead of clicking the link.) So the form should definitely show in this instance.

In the first case (wp-login.php?checkemail=confirm), the user is presented with "Check your e-mail for the confirmation link" but should still be presented with the form. Though they said they have forgotten their password, their current password still works, and they could still log in. So no harm in showing the form there either.

nacin4 years ago

comment:3 janeforshort4 years ago

This is an enhancement request, not a bug (which indicated broken functionality, not an awkward flow). We're already in freeze (beta, actually), so punting this to next release cycle.

comment:4 janeforshort4 years ago

  • Milestone changed from 2.9 to Future Release
  • Type changed from defect (bug) to enhancement

comment:5 nacin4 years ago

  • Keywords commit added; login confirmation mail removed
  • Milestone changed from Future Release to 3.0

Should either be committed or closed as wontfix.

comment:6 dd324 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [12981]) Show login form upon email-sent for recover/reset passwords. Props nacin. Fixes #11141

comment:7 dd324 years ago

I've commited this, for consistancy sake. Having mearly the message there without a form seems out of place.

Other systems often display the key seperately, In that case, WordPress could offer a form to enter the key in perhaps.

The commit also included a change to prettify the die messages upon email failing to send.

Note: See TracTickets for help on using tickets.