WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 22 months ago

#11151 closed defect (bug) (worksforme)

Common White Screen of Death in wpdb

Reported by: nutsmuggler Owned by:
Milestone: Priority: normal
Severity: major Version: 2.8.5
Component: Database Keywords:
Focuses: Cc:

Description

I imported some 10.000 users into WP through a custom script, using wp_insert_users().
Import successful, I could log in with new users.
Yet wp-admin/users.php page fails to load the users table; I got the admin header and menu but the page stopped loading when querying the DB for the users data.
I set WP-DEBUG to true, but still no error. NO errors in the server log also.
I eventually had to add

define('WP_MEMORY_LIMIT', '64M');

to wp-config.php to get the users.php page working.
The problem here is that the page doesn't issue the usual PHP memory limit fatal error, I had to guess to sort it out.

Change History (11)

comment:1 @scribu6 years ago

  • Keywords reporter-feedback added; users removed

Did you set WP_DEBUG or WP-DEBUG ? The first one is correct.

comment:2 @voyagerfan57615 years ago

  • Cc WordPress@… added

comment:3 @miqrogroove5 years ago

  • Component changed from Users to Database
  • Keywords needs-patch added; reporter-feedback memory limit removed
  • Owner set to ryan
  • Severity changed from normal to major

See also #12257

The white screen of death is caused by inappropriate use of error control operators in wp-db.php.

comment:4 @nacin5 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

users.php: #11914. wpdb: #12257.

comment:5 @miqrogroove5 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Summary changed from users.php fails silently if WP_MEMORY_LIMIT is exceeded to Common White Screen of Death in wpdb

We should keep separate tickets for the memory issue and the error crashes. Memory exhaustion is not the only condition that triggers WSOD in WordPress.

comment:6 @nacin5 years ago

Memory exhaustion for users.php and wpdb have their own tickets. I was thinking we should open tickets for specific conditions that cause WSOD.

comment:7 @nacin5 years ago

  • Milestone set to Future Release

comment:8 @nacin5 years ago

  • Cc westi added
  • Milestone changed from Future Release to 3.1
  • Owner ryan deleted
  • Status changed from reopened to assigned

Per #15402.

comment:9 @miqrogroove5 years ago

XMB had this same problem a couple years ago. The authors had error-controlled all of the MySQL function calls because they didn't know how to make them behave in a useful manner in debug mode. It had to be PHP 4 compatible, so all I did was wrap each function with a custom error handler. In this case it only writes to the system log and throws a generic 500 message, but that part is easily customized.

http://svn.xmbforum.com/wsvn/XMB/xmb19x/trunk/source/db/mysql.php

comment:10 @nacin4 years ago

  • Milestone changed from 3.1 to Future Release

comment:11 @wonderboymusic22 months ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

These are anecdotal issues from 3-4 years ago

Note: See TracTickets for help on using tickets.