WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11155 closed enhancement (duplicate)

Move [gallery] styling to actual CSS and take it out of the body

Reported by: zamoose Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Gallery Keywords: gallery
Focuses: Cc:

Description

I agree 100% with WP-Engineer's take on the nastiness of embedding the styling for gallery inserts inline http://wpengineer.com/a-solution-for-the-wordpress-gallery/. I would advocate that his solution be integrated into the core, as it is far more flexible and allows theme authors to restyle galleries on the fly.

I'll attach a diff for src/trunk/wp-includes/media.php presently.

Attachments (1)

media.diff (1.6 KB) - added by zamoose 6 years ago.
First crack at PHP alterations.

Download all attachments as: .zip

Change History (4)

@zamoose6 years ago

First crack at PHP alterations.

comment:1 @dd326 years ago

This may be better suited to one of the many open tickets on this: http://core.trac.wordpress.org/search?q=gallery+css A lot probably need to be closed as a duplicate of the one with the most discussion.

comment:2 @zamoose6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Gah, dd32, you're right. I don't know why #10734 didn't crop up before when I searched.

Closing as dupe, at least in intention.

comment:3 @mtekk6 years ago

  • Milestone 3.0 deleted
Note: See TracTickets for help on using tickets.