WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 8 weeks ago

#11158 closed defect (bug) (invalid)

Cannot Link Phrases With @ In Them (IE Only)

Reported by: miqrogroove Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version: 2.8.4
Component: TinyMCE Keywords: needs-patch
Focuses: Cc:

Description

Steps to Reproduce:

  1. Type a phrase into a new post body, such as "Old MacDonald @ The Farm"
  1. Highlight the phrase.
  1. Click the Link button.
  1. Type in any innocuous URL such as http://www.google.com/

Expected result:
Phrase should become linked. :)

Actual result:
Phrase is replaced by URL. :(

Workaround:
User must switch to HTML view and enter the link code manually.

Change History (13)

comment:1 @azaozz6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Seems to work properly in trunk. Was probably fixed in the newer version of TinyMCE.

comment:2 @miqrogroove6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Broken in RC1.

comment:3 follow-up: @ryan6 years ago

Working here with Firefox 3.5.6 on Mac OS.

comment:4 follow-up: @miqrogroove6 years ago

  • Summary changed from Cannot Link Phrases With @ In Them to Cannot Link Phrases With @ In Them (IE Only)

Fair enough.

comment:5 in reply to: ↑ 4 @westi6 years ago

Replying to miqrogroove:

Fair enough.

Which version of IE are you seeing the issue in (and on what operating system)

This information will help us chase down this issue.

comment:6 @miqrogroove6 years ago

Windows XP. IE6 and IE8 both broken.

comment:8 @dd326 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Works for me under IE8 on that linked site.

Closing as invalid due to this NOT being a WordPress bug, Please report it to the Tiny MCE Bug tracker on Sourceforce

It seems to work for most(based on info here) so its probably an edge case with your setup which TinyMCE developers would know more info about.

comment:9 @miqrogroove6 years ago

Once again, thanks for nothing.

comment:10 @dd326 years ago

Once again, thanks for nothing.

What do you expect? Its NOT a bug in WordPress? If you can reproduce it on a non-wordpress site, it points the fact that its a problem in TinyMCE itself, and not the integration with WordPress. We're WordPress developers, NOT TinyMCE Developers, whilst some know enough to diagnose basic issues, Complex issues such as yours requires someone with itnernal knowledge of the product, You'll only find those on the proper channels for getting TinyMCE bugs fixed.

comment:11 @ninjaWR6 years ago

Try making a link without the http://. The wording is as it's supposed to be, but the link is relative to the domain (localhost/google.com). With the http://, the wording does change as miqrogroove said.

It happens to me at both a WordPress based site, and the TinyMCE example page.

comment:12 in reply to: ↑ 3 @Denis-de-Bernardy6 years ago

Replying to ryan:

Working here with Firefox 3.5.6 on Mac OS.

OT: I am *very* surprised. I was convinced you were a Linux junkie. :-)

comment:13 @DrewAPicture8 weeks ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.