WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

#11177 closed enhancement (duplicate)

Page Order Explanatory Text Change

Reported by: jrgkgb Owned by:
Milestone: Priority: normal
Severity: trivial Version: 2.9
Component: Editor Keywords: has-patch commit
Focuses: Cc:

Description

A Humble Request

I almost hate to bug everyone with something so small, but it's
something that has begun to take up a fair amount of time.

On the "Edit Page" interface, underneath the "Page Order" field is
text that states "(We know this is a little janky, it'll be better in
future releases.)"

While I appreciate the acknowledgment of the jankiness and it never
bothered
me working with WP on my personal sites, I now regularly set up Wordpress
sites for clients, many of whom I have talked into migrating from another
CMS. The Order interface is in fact a little janky but it's also quite
functional, and to a client who is new to Wordpress it's a bit of a turn
off.

I wouldn't mention it if I hadn't had to defend it to clients a couple of
times, to the point where I have begun suppressing it for new client
sites I
roll out.

It occurs to me that I'm probably not the only one with this issue, and
that
removing the text in the core would a) not have any functional impact
whatsoever and b) would aid in the shift from thinking of Wordpress as a
blogging platform to thinking of it as the world class CMS that it's
rapidly
becoming.

Obviously, a nicer interface for ordering pages would be nice too but
given
the number of awesome plugins for page management out there, not a
priority.

I have been playing with the 2.9 beta (loving the image editor guys!) and
hope this suggestion comes at a point where it might be acted on.

Thanks!

Attachments (1)

11177_janky.patch (840 bytes) - added by nacin 12 years ago.
This would remove the "janky" text (though at the expense of translations).

Download all attachments as: .zip

Change History (4)

#1 @nacin
12 years ago

  • Milestone changed from Unassigned to Future Release

See also #6362, #2720

@nacin
12 years ago

This would remove the "janky" text (though at the expense of translations).

#2 @scribu
12 years ago

  • Keywords has-patch commit added; Edit Page removed
  • Milestone changed from Future Release to 2.9

+1: Don't apologize. It creates more problems than it solves.

#3 @westi
12 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for the patch.

I am going to close this as a dupe of #6362 and we will fix it there

Note: See TracTickets for help on using tickets.