WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#11199 closed defect (bug) (fixed)

Previewing pages with 'Pending Review' status with Permalinks turned on doesn't work

Reported by: dj-wp Owned by:
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.8.5
Component: Administration Keywords: has-patch tested
Focuses: Cc:

Description

Hi,

I am running a fresh WordPress install using version 2.8.5. This scenario only happens with Permalinks turned on.

Reproducing the bug

  1. Click the "Add New" under "Pages" in the admin menu.
  1. Define a title and a content.
  1. Change status to "Pending Review".
  1. Click "Save as Pending".
  1. The "View Page" and "Preview" links do not have the "page_id" GET parameter as part of their URLS. Therefore, the page cannot be previewed.

I have checked the WP trunk and it doesn't seem to have been fixed yet. I have modified the core to make it work. Here's a patch for it, it seems to be working fine on my install.

Attachments (1)

link-template.patch (719 bytes) - added by dj-wp 4 years ago.

Download all attachments as: .zip

Change History (3)

dj-wp4 years ago

comment:1 scribu4 years ago

  • Keywords tested added
  • Milestone changed from Unassigned to 2.9

Confirmed behaviour in trunk, with permalinks turned on.

Patch works.

comment:2 ryan4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [12245]) Fix preview of pending pages with permalinks on. Props dj-wp. fixes #11199

Note: See TracTickets for help on using tickets.