WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

#11238 closed defect (bug) (duplicate)

sanitize_title error with %20 in the title

Reported by: davidbolufer Owned by: ryan
Milestone: Priority: normal
Severity: major Version: 2.8.5
Component: Permalinks Keywords: sanitize_title needs-patch
Focuses: Cc:

Description

If the title of the post contain %20, Wordpress doesn't sanitize the permalink correctly

Title: Ebay glittery lurex over the knee socks and 80%20 royal blue ankle wedges

Permalink: ebay-glittery-lurex-over-the-knee-socks-and-80 -royal-blue-ankle-wedges

Change History (5)

#1 @scribu
12 years ago

  • Keywords needs-patch added; permalink removed
  • Milestone changed from Unassigned to 2.9

#2 @scribu
12 years ago

  • Severity changed from normal to major

Confirmed in trunk. Causes post to be unaccesible.

#3 @ryan
12 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

See #3329

#4 @davidbolufer
12 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Sorry but I applied the patch #3329 and the patch #10758 and the error continue, with this post_title Manelo%20Feo I get this post_name manelo%20feo in SQL and "manelo feo" in the browser.

I think the error doesn't be solved.

#5 @scribu
12 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

That just means the patch needs more work.

This ticket is still a dupe. Please post your feedback on that ticket instead, as it's still open.

Note: See TracTickets for help on using tickets.