WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#11259 closed enhancement (fixed)

Undo should not fade, instead it should update status

Reported by: lloydbudd Owned by:
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.9
Component: Trash Keywords: Comments, Trash
Focuses: Cc:

Description

Undo should not fade, instead it should update status

ENV: 2.9-beta-1 (TRUNK r12273)

When you click "Trash" the comment is replaced by:

"Comment by Mr WordPress moved to the trash. [Undo]"

And some seconds later that fades.

It should not fade, because this interrupts reviewing other comments as the display shifts.

If you have a busy blog and have Moved to Trash a number of comments, this can be disruptive.

If for technical reasons, the "Undo" can't remain available, then it would be better for just the [Undo part to fade out:

"Comment by Mr WordPress moved to the trash."

Bonus would be a link to the comment in the trash.

Attachments (1)

11259.diff (476 bytes) - added by caesarsgrunt 5 years ago.
Remove timeout for trash notices

Download all attachments as: .zip

Change History (7)

comment:1 follow-up: @caesarsgrunt5 years ago

  • Type changed from defect (bug) to enhancement

This isn't a bug; it is the (currently) intended behaviour.

Personally, I don't think the slight display shift when a single undo message fades is a problem, although I agree that it becomes a problem with multiple notices fading.
This is fixed in my latest patch on #4529, which I am waiting for someone to commit. This patch hides any existing undo notice when a second one is shown, so that only one is shown at a time.

We could perhaps reduce or eliminate the display shift by scrolling up a corresponding amount when the notice is hidden, if you think it is a problem even with one notice.

Alternatively, we could make it so that the trash notices don't fade out at all, as you suggest.

Perhaps we need some more opinions on what should happen...

comment:2 @caesarsgrunt5 years ago

Also - no, there is no technical reason why the undo link has to be hidden.

@caesarsgrunt5 years ago

Remove timeout for trash notices

comment:3 @caesarsgrunt5 years ago

If it is decided that not fading at all is the way to go, the above patch does that.

comment:4 in reply to: ↑ 1 @lloydbudd5 years ago

Wow, thanks for quickly getting the patch up!

Replying to caesarsgrunt:

This isn't a bug; it is the (currently) intended behaviour.

Sure, implemented as spec'd -- just the spec had the behavioral bug.

Personally, I don't think the slight display shift when a single undo message fades is a problem

I'd argue that simple consistent behavior is best. Although the fade feels slick, it doesn't actually help the UI. Movement should only happen directly after interaction (press key / mouse click).

comment:5 @caesarsgrunt5 years ago

Well, the purpose of the current fading (the fade is not important; perhaps I should say disappearing) was to help the UI by keeping the interface clear of no-longer-needed clutter.

That said, I'm very happy to switch to keeping the notices there if that's what others want; I really don't mind either way and haven't actually thought much about the advantages/disadvantages of fading/not-fading.

On #4529 you'll find an alternative version of my latest patch, which includes the changes in this patch. It would be the one to commit, rather than this. (Or otherwise I'll have to redo that patch again...)

comment:6 @azaozz5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [12278]) Stop the fade-out of the Undo notices on Edit Comments screen, props caesarsgrunt, fixes #11259, see #4529

Note: See TracTickets for help on using tickets.