WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11273 closed enhancement (wontfix)

Comments: Edit button is not necessary with Quick Edit button

Reported by: lloydbudd Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Comments Keywords:
Focuses: Cc:

Description (last modified by lloydbudd)

Comments: Edit is not necessary with Quick Edit

Enhancement, ENV: 2.9-beta-1 (trunk r12287)

In Replying to #11258comment:7 caesarsgrunt]:

BTW, why not merge Edit and Quick Edit - always Quick Edit if there is JS, and link to Edit otherwise? We could add a link to the full edit page within Quick Edit - call it "advanced" or something.

@caesarsgrunt you make an excellent point!

Add date manipulation to "Quick Edit"... consistent with Post/Page quick edit.

"Quick Edit" button should be removed. "Edit" should do "quick edit" if JS is enabled.

ADDITIONAL DETAILS

As far as I can tell, the Edit action only other additional action is to also change the status, but that can quickly be done directly from the Comments web page (edit-comments.php). No reason to clutter with an "Advanced" button/option on the page.

This does make it inconsistent with Posts/Pages which have "Quick Edit | Edit", but this inconsistency seems appropriate in context.

Please leave the target milestone as 3.0, ie not work on this ticket until after 2.9 has shipped -- ship it!

Change History (33)

comment:1 Denis-de-Bernardy4 years ago

  • Keywords early added; buttons quick edit edit comments removed

comment:2 lloydbudd4 years ago

  • Description modified (diff)

comment:3 lloydbudd4 years ago

  • Description modified (diff)

comment:4 lloydbudd4 years ago

  • Summary changed from Comments: Edit is not necessary with Quick Edit to Comments: Edit button is not necessary with Quick Edit button

comment:5 in reply to: ↑ description ; follow-up: nacin4 years ago

I was working on a patch for this the other day and can probably get it up here when I have a chance.

From #11295, caesarsgrunt:

  • Replace both links by one, called Edit.
  • Make the new link go to the edit page when JS is not available, but otherwise perform as Quick Edit currently does.
  • Add an Advanced link to the Quick Edit dialog, which takes the user to the Edit page.

Replying to lloydbudd:

No reason to clutter with an "Advanced" button/option on the page.

I'd have to go with yes to an edit link here, no reason to hide it. Also, the new comment meta plays a role here, as that may appear on the Edit page but not under Quick Edit, so you definitely can't hide it.

comment:6 in reply to: ↑ 5 lloydbudd4 years ago

Replying to nacin:

I'd have to go with yes to an edit link here, no reason to hide it. Also, the new comment meta plays a role here, as that may appear on the Edit page but not under Quick Edit, so you definitely can't hide it.

nacin, great insights! I had forgot about comment meta, mostly because I have not seen it in use. It does not show up on edit currently -- which I think is a good thing.

I think there is an opportunity to move the platform forward and unlike how "custom fields" are loaded for Posts, not to do include unless programatically included by a plugin.

With simplified comment editing, providing an example implementation of how to expose additional fields seems like the right balance, but not to do expose them in core.

comment:7 caesarsgrunt4 years ago

  • Cc caesar@… added

comment:8 follow-up: Denis-de-Bernardy4 years ago

suggesting we close this, given nacin's insight on comment meta.

comment:9 in reply to: ↑ 8 nacin4 years ago

Replying to Denis-de-Bernardy:

suggesting we close this, given nacin's insight on comment meta.

Actually, I was only offering that in the context of whether you still need to include an "Advanced" link from Quick Edit to the Edit screen, or entirely hide the comment.php?action=edit screen for those with JavaScript.

That said, taking it a step further to where Denis went, I do agree that both the Edit and Quick Edit links are probably necessary, at least in this case.

comment:10 follow-up: caesarsgrunt4 years ago

Since needing the current Edit is likely to be a fringe case, why not either (a) have an Advanced link as previously discussed, or (b) make it so plugins can add it back if they want it due to other features they add?
After all, most things which are added to the Edit page could equally well be added to Quick Edit.

comment:11 in reply to: ↑ 10 ; follow-up: nacin4 years ago

Replying to caesarsgrunt:

Since needing the current Edit is likely to be a fringe case, why not either (a) have an Advanced link as previously discussed, or (b) make it so plugins can add it back if they want it due to other features they add?

That's an interesting idea. I would suggest having an Advanced link AND allow plugins to add an Edit link to the comment row. Plugins can already modify the action links using the comment_row_action filter. But, instead of forcing them to rebuild the URL, I'm thinking we should then create a way for plugins to easily do so.

First route: if ( ! apply_filters( 'comment_row_action_edit', false ) ) unset( $action['edit'] );

Second route: Default filter on comment_row_action to remove $actionedit?, which could then be removed by a plugin. This seems to make more sense but would probably confuse a plugin developer looking at _wp_comment_row() and not realizing there is a default filter at work.

Also, there should be a way to moderate / change the status of a comment from Quick Edit. Currently, when you click Quick Edit, you lose the action links. (This is true and is a UI issue now, but when you make Quick Edit primary, it comes more into focus.)

After all, most things which are added to the Edit page could equally well be added to Quick Edit.

Actually... looking through comment.php, I don't see a single hook, which given the new comment meta in 2.9 is pretty important. Am I just missing something?

comment:12 in reply to: ↑ 11 ; follow-up: caesarsgrunt4 years ago

Replying to nacin:

I would suggest having an Advanced link AND allow plugins to add an Edit link to the comment row.

That's a good idea.

Also, there should be a way to moderate / change the status of a comment from Quick Edit. Currently, when you click Quick Edit, you lose the action links. (This is true and is a UI issue now, but when you make Quick Edit primary, it comes more into focus.)

I don't think it matters. Why would you want to change its status whilst you were editing it?
That said, if this is wanted we could add a select/dropdown for it to Quick Edit.

comment:13 in reply to: ↑ 12 ; follow-up: nacin4 years ago

Replying to caesarsgrunt:

I don't think it matters. Why would you want to change its status whilst you were editing it?

Just a quick example: If someone spelled something wrong, or perhaps formatting got screwed up, you click "Quick Edit," make the change, then "Update Comment," then wait for it to fade back in again, have to find and click "Approve". I just think it can probably be a little more intuitive.

comment:14 in reply to: ↑ 13 caesarsgrunt4 years ago

Replying to nacin:
Yeah; I see what you mean.

comment:15 westi4 years ago

  • Keywords needs-patch added

comment:16 azaozz4 years ago

Seems we can do that easily with CSS. Can add .edit-link class to the Edit link and hide it by default when JS is enabled. If plugin needs it, it can define #the-comment-list .edit-link and show it.

comment:17 caesarsgrunt4 years ago

+1 to Azaozz's solution.

comment:18 janeforshort4 years ago

I might be misunderstanding one of the suggestions above, so forgive me if I have.

I want to say I'm +1 to removing the Edit link and adding the extra editing capabilities to Quick Edit view, but I have reservations. Mainly because I have JavaScript enabled, but for some reason there are times when my setup (Macbook Pro, FF 3.5) gets confused by JS and it doesn't work correctly, and the only way I can edit things is by going to the actual edit screens for posts or comments. I doubt I'm the only person using WP who's had this experience.

Side note: if the edit link does get removed, I definitely do not want the Quick Edit link to be relabeled as Edit. We need to keep consistency in the labels to set appropriate expectations of action. In that case if no-JS will substitute going to the edit screen for the quick view, it can substitute the link as well. That said, if the screen exists, it seems weird not to offer someone access to it unless they don't have JS.

comment:19 hakre4 years ago

I'm missing a bit of a prototype patch here so that it's easier to discuss. It would be nice to actually have some buttons to click so to better see how this is going to feel. Normally I would say that it's good that the user can decide which editor to load.

comment:20 nacin4 years ago

  • Keywords early needs-patch removed
  • Milestone 3.0 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

For reasons described herein.

comment:21 caesarsgrunt4 years ago

Well, I'll just repeat that my users find it very confusing having two edit links, for obvious reasons.

comment:22 jane4 years ago

Accessibility it more important. Any user should be able to understand the distinction, as it's an application-wide convention. If they can't, even after seeing it in action once or twice, then they fall outside the range of the average user. Someone can write a plugin to remove the edit link if they think their users will have that much trouble.

comment:23 caesarsgrunt4 years ago

Yes, after being told and seeing it in action once or twice then of course most users of average intelligence will be able to remember.

My point is that an interface shouldn't be so unintuitive that users have to be told and see it in action once or twice and then have to remember why there are two links serving the exact same purpose.

If you look back at the original ticket and ensuing discussion, you'll see that my proposal created no accessibility problem as it uses the concept progressive enhancement, as used in the rest of WP and any accessible website. This means that if users do not have the required javascript to use Quick Edit, they are presented with the old edit link. Furthermore, I mentioned the idea Quick Edit could contain a link to "Advanced Edit".

There is no accessibility loss caused by this suggested change, just a usability fix.

comment:24 jane4 years ago

I disagree that keeping standardized action links in unusable. This is a wontfix for 3.0. Removing the Edit link can be left to a plugin if someone feels strongly, like @caesarsgrunt.

comment:25 caesarsgrunt4 years ago

Yes, I realize that plugins can be used to fix WP's flaws, and I do often include a generic bugfix plugin in my installations of WordPress, for bugs the core devs have vetoed.

However, I think that bugfixes and usability fixes generally should be integrated into the WP core, and in particular I think that issues like this should not be closed as wontfix just on one person's opinion, when everyone else in the (admittedly brief so far) discussion has been in favour of it.

I am becoming rather fed up with this attitude and I know that other contributors are too.

comment:26 follow-up: jane4 years ago

We are past feature freeze for 3.0, so anything that hasn't already been agreed upon by the lead developers as a task it too late for this version.

If two people have a differing opinion on what is more usable, the answer is to test it with real users. Not with one person's clients, but in regular usability testing with a broad range of users. Action links on admin screens were a big part of the testing on 2.5, and the way we designed 2.7 (which is what this thread is about, the 2.7 action link design) was based purely on that testing. If you would like to suggest another round of testing, that would be fine, but saying your opinion of a usability "bug" is more valid than the formal testing we did is just as aggravating. You assume decisions I promote are based on my opinion, and sometimes that's the case, but more often (and in this case) it's based on testing.

And in some cases, a decision may be made not based only on what functionality exists today, or through plugins, but based on where we think the functionality will be going. If people missed a discussion or background on a decision (no one is involved in every single discussion in IRC, wpdevel, forums, hackers, ui group, etc) and think a decision the lead team has made is bad, if the person would ask why a decision had been made before complaining about it and saying it is ill-considered, maybe we could avoid some of this contention.

comment:27 in reply to: ↑ 26 caesarsgrunt4 years ago

Replying to jane:

We are past feature freeze for 3.0, so anything that hasn't already been agreed upon by the lead developers as a task it too late for this version.

Certainly, but the normal way of punting a ticket is to change it to the next version (or, slightly contentiously, to Future Release) rather than just close it as wontfix which means, believe it or not, that it has been decided not to fix it.

If two people have a differing opinion on what is more usable, the answer is to test it with real users. Not with one person's clients, but in regular usability testing with a broad range of users. Action links on admin screens were a big part of the testing on 2.5, and the way we designed 2.7 (which is what this thread is about, the 2.7 action link design) was based purely on that testing. If you would like to suggest another round of testing, that would be fine, but saying your opinion of a usability "bug" is more valid than the formal testing we did is just as aggravating. You assume decisions I promote are based on my opinion, and sometimes that's the case, but more often (and in this case) it's based on testing.

Sorry, I didn't know you had done specific testing regarding the issue of removing the Edit link, since you never mentioned this. perhaps you would post the results, or give us a link if they are already online?
Nor had I realised that this action link design was a specific part of the design for 2.7; I had assumed it was just an artifact from the combination of the old edit system and the new Quick Edit system. Again, you didn't mention this when closing the ticket.
Further, as anyone reading the ticket and comments can see, this is not merely my opinion against usability test results. This is the opinion of everyone else involved in the ticket except you, against what was presented as your opinion but you are now saying is based on UX testing. Either way, the opinions of a group of WP contributors should be considered and respected, even if it is eventually overruled by UX testing.

And in some cases, a decision may be made not based only on what functionality exists today, or through plugins, but based on where we think the functionality will be going. If people missed a discussion or background on a decision (no one is involved in every single discussion in IRC, wpdevel, forums, hackers, ui group, etc) and think a decision the lead team has made is bad, if the person would ask why a decision had been made before complaining about it and saying it is ill-considered, maybe we could avoid some of this contention.

This is not a one-off issue, it's a widespread opinion that the core devs are heavy handed in closing tickets they don't personally agree with.
If you consider this opinion unjustified it is up to you, the core devs, to fix it. Have you considered the fact that maybe it should be you, when you close a ticket, who should explain why "why a decision had been made" in order to avoid some of this contention?
In this case, for example, you clearly presented the decision as a personal one. If that was not the case, you have unnecessarily created a bad impression of yourself as a core dev, which you could have avoided by behaving in a more professional manner by explaining that it was in fact a team decision based on UX testing (if this is really the case).
It's no use blaming everyone else. Look at the root of the misunderstanding.

comment:28 caesarsgrunt4 years ago

Sorry if the last bit of that comes off as a personal attack, Jane. I admire you for a lot of the work you do, and I respect your opinions, but I do think you are one of the worst of the core devs when it comes to ticket vetoing for apparently personal reasons, even if those are not the real reasons. It makes me and others very angry, and you would certainly do well to try to explain your reasons better if they are not just personal decisions.

comment:29 jane4 years ago

There was no Edit link per comment in 2.5, the comment author name performed as an Edit link. It was changed in 2.7 per user feedback that over and ever contained, "I wish there was just an Edit link." The testing report was posted on the dev blog when that was done.

comment:30 caesarsgrunt4 years ago

Of course; I'd forgotten.

I'd be interested to see the results of your specific usability testing of the two edit links. Please quote it or give a url. Surely that's not too hard if it really exists? Google site:wordpress.org edit link usability testing returns no relevant results.

comment:31 jane4 years ago

@caesarsgrunt: As I said above, the testing was done on the version before the Edit link (2.5), and the Edit link was put in as a response to testing results. If you want to suggest new testing, as I mentioned before, feel free to. Just yesterday in the #wordpress-dev chat, in fact, I asked people if there were any areas they wanted tested when I conduct usability testing this coming week in Austin. No one brought up the edit link, because it apparently was not a priority for the developers involved. Sadly you didn't come to that meeting, nor did you comment on the meeting agenda or summary on wpdevel.wordpress.com to request it, nor have you just made the statement on this ticket, "Why don't we test it against a prototype without the edit link and see how they compare?" Seriously, all it takes is someone asking, and we can test it.

If instead you'd rather question my integrity and call me a liar, which your comment basically does, then there is a bigger problem here than the edit link. If you really think this an appropriate way to gain support for an idea, then we have very different views on how to win friends and influence people.

comment:32 caesarsgrunt4 years ago

Jane, my intention was not to question your integrity. Sorry if it comes across that way. Rather, I was just asking for the testing which you explicitly said that you had done, so that I could see the results. Not because I thought you were lying. Because I was interested in the results.
Since you now say that such testing was not, after all, done, I'm not sure what to think, since that seems to reinforce the concept that this was just a personal veto on the ticket with no basis other than your own opinion.
Anyway, let's not get back to that; we're just going round in circles.

As you say, I haven't been involved in dev discussions at all recently. I've been at sea and in remote areas with no internet access, and I've only just got to an area with basic internet access in the last couple of days. I'm still not in a position to get involved in a big way, at present.

I'm not going to get involved in further discussion regarding why the ticket was closed. If we can have a constructive discussion about the issue, I'll take part.

Yes, I do suggest that testing be done if it hasn't. I'm not in a position to organise it myself, but if anyone is taking suggestions for areas to do testing I would suggest both that and ordering of comments in the admin (a separate issue) as the main issues with the comment management interface.

comment:33 jane4 years ago

@caesarsgrunt: Please read more carefully, as you're claiming I said things that I did not say. I never said we tested the edit link. I said we added the edit link in response to testing the comment action links in 2.5. The specific quotes from above:

"Action links on admin screens were a big part of the testing on 2.5, and the way we designed 2.7 (which is what this thread is about, the 2.7 action link design) was based purely on that testing,"

and the follow-up detail:

"There was no Edit link per comment in 2.5, the comment author name performed as an Edit link. It was changed in 2.7 per user feedback that over and ever contained, 'I wish there was just an Edit link.'"

Either you're ignoring the actual words I'm posting, or you're deliberately pretending I said things I didn't say. Either way, I'm done with discussion.

Note: See TracTickets for help on using tickets.