WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#11284 closed defect (bug) (worksforme)

Gallery Popup Extremely Slow (IE only)

Reported by: miqrogroove Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version: 2.8.5
Component: JavaScript Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Visit the post editor of any post that has 40+ images attached.
  1. Click the Add an Image button.
  1. Click the Gallery tab.

Expected results: All tabs should open quickly.

Actual results: In Internet Explorer (tested with IE6), the From Computer, From URL, and Media Library tabs open quickly. The Gallery tab opens, but grinds to a hault as soon as it seems to start fetching the image thumbnails. In some tests, IE has thrown a slow script error.

I believe this problem affects all WP versions, going back to at least 2.6.

Attachments (1)

ticket-11284-error-screenshot.gif (10.5 KB) - added by miqrogroove 6 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 @miqrogroove6 years ago

  • Summary changed from Gallery Popup Extermely Slow (IE only) to Gallery Popup Extremely Slow (IE only)

comment:2 in reply to: ↑ description ; follow-up: @lloydbudd6 years ago

  • Milestone changed from 2.9 to Future Release
  • Severity changed from major to normal

Thanks for continuing to suss out interesting problems!

Replying to miqrogroove:

Steps to reproduce:

  1. Visit the post editor of any post that has 40+ images attached.

Edge case... though a few VIPs on WordPress.com make posts like this regularly. I believe they have their own work flow (around this possibly), will follow up with them as well to see the impact of issue.

I believe this problem affects all WP versions, going back to at least 2.6.

WordPress version? You did identify what versions of WordPress you did test -- trunk and then most recent release being the most interesting.

Browser version? And you did not identify what exact build of IE6 and on what OS version. Also, does this occur in newer versions of IE?

Pushing out to Future Release. Not a candidate for 2.9 at this point even with that additional information unless really compelling user cases and clean (obvious) page.

comment:3 @mtdewvirus6 years ago

  • Cc mtdewvirus@… added

comment:4 in reply to: ↑ 2 @lloydbudd6 years ago

  • Keywords reporter-feedback added

Replying to lloydbudd:

Pushing out to Future Release. Not a candidate for 2.9 at this point even with that additional information unless really compelling user cases and clean (obvious) page.

Sorry, should end: "clean (obvious) patch."

comment:5 @miqrogroove6 years ago

IE 6.0.2900.2180.xpsp_sp2_gdr.070227-2254 is the one that gives me trouble. It's not just me though. I will ask around if anyone else has a specific version in mind. This has been an ongoing problem with every version of WP I've installed. Did not test 2.9 yet.

JavaScript is not one of my better languages, so I probably wont even debug this one.

comment:6 @lloydbudd6 years ago

  • Version set to 2.8.5

comment:7 @miqrogroove6 years ago

  • Keywords reporter-feedback removed

IE6 is the only one in the working-but-too-slow category.

comment:8 @hakre6 years ago

Tested against 2.9 trunk, when I click the "Add an Image" button with IE6.xp.sp3 I only see the loading bar and nothing else happens. Looks like that the media thickbox doesn't work with IE6 any longer.

I suggest that an overall IE6 acceptance test should be run over current trunk to find out where the mess is sitting. I smeel that IE6 is not properly tested against any longer.

For me title of this ticket could be: Media Popup does not work any longer in IE 6

comment:9 @azaozz6 years ago

Works properly here in IE6 ver. 6.0.2900.5512.xpsp_sp3. What happens if you right-click and open in a new window? May be dependent on number of images in the gallery tab (tested with 20) and/or browser/server settings.

comment:10 @miqrogroove6 years ago

IE6 Add an Image still works for me too.

comment:11 @hakre6 years ago

I have left it open in a longer test and I only do see the loading-bar of thickbox, background of the page is darkened, but the thickobx never shows up. Might be anohter problem related to WP_DEBUG or script concatination being off. Please ignore then.

comment:12 @azaozz5 years ago

No extra feedback or patch in over a year.

comment:13 @azaozz5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

comment:14 @ocean905 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.