WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#11293 closed defect (bug) (fixed)

Dropdown filter and dashboard widget column are too narrow for Czech

Reported by: pavelevap Owned by:
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.9
Component: UI Keywords: has-patch
Focuses: Cc:

Description

As you can see on attached pictures, there are problems with styling for non-english version of WordPress.

Ad Czech_1.png - this problem on Dashboard was not in WP 2.8.x but is in latest trunk.

Ad Czech_2.png - this problem appears on many dropdown menus in administration. Fields are limited for original english terms, but translated terms are sometimes longer.

Attachments (3)

Czech_1.png (12.8 KB) - added by pavelevap 6 years ago.
Czech_2.png (12.4 KB) - added by pavelevap 6 years ago.
czech-style-fix.diff (107.5 KB) - added by Nao 6 years ago.
CSS changes for wide i18n'd strings in admin panels

Download all attachments as: .zip

Change History (16)

@pavelevap6 years ago

@pavelevap6 years ago

comment:1 @dd326 years ago

  • Component changed from Graphic Design to UI
  • Keywords CSS removed

Given this is UI related, What Browser, Browser Version, and Platform have you tested this on? (ie. which one was that screenshot taken under?)

comment:2 @pavelevap6 years ago

Sorry, I forgot to mention browsers.

First problem is related only to IE8 (FF 3.5.x is OK), but the second problem is visible in all browsers (IE8 and FF 3.5.x).

comment:3 @lloydbudd6 years ago

  • Component changed from UI to i18n
  • Owner set to nbachiyski

@Nao6 years ago

CSS changes for wide i18n'd strings in admin panels

comment:4 @Nao6 years ago

  • Keywords has-patch added
  • Summary changed from Wrong styling for localized version to Dropdown filter and dashboard widget column are too narrow for Czech

czech-style-fix.diff adds white-space: nowrap; rule to the problematic "a" element in Dashboard "Right Now" widget.

It also adjusts the width of "select" elements on wp-admin/edit.php.

Tested on Windows IE 7, IE 8, FF 3.5 + Mac Firefox 3.5, and Sarafi 4.

comment:5 @janeforshort6 years ago

Just a general note: FF3 still accounts for about 30% of FF users, so we should test that as well as 3.5 (FF2 is only around 1%).

comment:6 @markjaquith6 years ago

  • Component changed from i18n to UI
  • Owner nbachiyski deleted

Tested in FF3.0 — looks fine. Seems like low-impact CSS.

comment:7 @markjaquith6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [12357]) Fix some wrapping/cropping issues for verbose languages. props Nao. fixes #11293

comment:8 follow-up: @pavelevap6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Great, it works fine.

But I noticed one other small problem. When you look at first picture, numbers (of posts, tags, etc.) should be aligned to the right, I guess? It worked well in WP 2.8.6.

comment:9 in reply to: ↑ 8 @nacin6 years ago

Replying to pavelevap:

But I noticed one other small problem. When you look at first picture, numbers (of posts, tags, etc.) should be aligned to the right, I guess? It worked well in WP 2.8.6.

Can't reproduce in trunk (r12374). This should be aligning it right. Can you confirm it is left-aligned on your localized install?

126	#dashboard_right_now td.b {
127	        padding-right: 6px;
128	        text-align: right;
129	        font-family: Georgia, "Times New Roman", "Bitstream Charter", Times, serif;
130	        font-size: 14px;
131	}

comment:10 @pavelevap6 years ago

Sorry, I forgot to mention that this problem also appears only using IE8 (FF etc. are OK).

comment:11 @nacin6 years ago

Okay, I can confirm the behavior in IE6 and IE7. IE8 works fine though.

It's because of:

#dashboard_right_now td.first,
#dashboard_right_now td.last {
	width: 1px;
}

Trying to think of a solution, but not sure if its worth it if it only affects IE6 and IE7. Can you double-check your browser version? I'm running 8.0.6001.18702 on XP SP3.

comment:12 @pavelevap6 years ago

Yes, I am using IE8 (8.0.6001.18865) on Vista Business.

comment:13 @azaozz6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in [12382]

Note: See TracTickets for help on using tickets.