WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11301 closed task (blessed) (fixed)

Remove Gears

Reported by: ryan Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 2.8.6
Component: Performance Keywords: has-patch
Focuses: Cc:

Description

Gears is being phased out in favor of HTML5.

Attachments (3)

11301.diff (19.0 KB) - added by ryan 4 years ago.
11301-tools.diff (3.5 KB) - added by rmccue 4 years ago.
Remove Gears stuff from tools.php
11301-js.diff (6.5 KB) - added by rmccue 4 years ago.
Remove Gears JS files and entry in script-loader

Download all attachments as: .zip

Change History (31)

comment:1 ryan4 years ago

Also svn rm gears-manifest.php, wp-gears.js, and wp-gears.dev.js.

ryan4 years ago

comment:2 matt4 years ago

This is unfortunate, but okay, could you please link to the ticket for adding offline storage support when committing? Might be worth re-pinging the Mozilla folks helping us.

comment:3 caesarsgrunt4 years ago

Although Gears for Mac is no longer available, I think it's still available for Windows, isn't it?

comment:4 caesarsgrunt4 years ago

  • Type changed from defect (bug) to enhancement

Not a bug. Not sure that you could call it an enhancement either, but...

comment:5 ryan4 years ago

#7262 is the ticket for HTML5 caching. It's not looking good for using it for what we want to do though.

comment:6 lloydbudd4 years ago

  • Component changed from General to Performance

Some background info:

"the company is letting the sun set on its Gears project."

....

'We're continuing to support Gears so that nothing breaks for sites that use it. But we expect developers to use HTML5 for these features moving forward as it's a standards-based approach that will be available across all browsers.'"
http://latimesblogs.latimes.com/technology/2009/11/google-gears.html

Unfortunately a very small, but noticeable percentage of WordPress.com users (Gears usage has always been very small on wp.com) have complained about the stability of the browser after installing Gears.

comment:7 ryan4 years ago

  • Milestone changed from 2.9 to 3.0

Postponing to 3.0 per #wordpress-dev meetup.

comment:8 nacin4 years ago

One thing that can probably be done now is removing the conditional message "Turbo is not available for your browser." from tools.php.

There's no Turbo link in the header and no explanation of what Turbo is in tools.php, nor is the "Speed Up WordPress" section title present with gears unavailable, so it's quite the orphaned phrase.

The fact that it will be phased out and/or replaced soon is just another reason to axe that line.

comment:9 nacin4 years ago

  • Type changed from enhancement to defect (bug)

For 3.0 I suggest we adjust our browser detection and hide it for OS/browser pairs that don't support it.

Other than that, I suggest future release (perhaps even wontfix, and revive the ticket in the future) until it is no longer supported by the most recent version of all grade-A browsers.

comment:10 nacin4 years ago

  • Type changed from defect (bug) to enhancement

Didn't mean to change the type.

comment:11 follow-ups: jane4 years ago

I thought we agreed to leave it under Tools (for the reasons nacin suggests), but get rid of the Turbo link in the header (for all the other reasons). Can we just get rid of the Turbo link for now?

comment:12 in reply to: ↑ 11 nacin4 years ago

Replying to jane:

I thought we agreed to leave it under Tools (for the reasons nacin suggests), but get rid of the Turbo link in the header (for all the other reasons). Can we just get rid of the Turbo link for now?

I agree with that. We can stop calling it "Turbo" too.

comment:13 in reply to: ↑ 11 nacin4 years ago

Replying to jane:

I thought we agreed to leave it under Tools (for the reasons nacin suggests), but get rid of the Turbo link in the header (for all the other reasons). Can we just get rid of the Turbo link for now?

The Turbo link only shows up if the browser has Gears installed. (It shows up under Tools just as long as it isn't Opera, though it could realistically make a more rigorous check.) I'm fine with getting rid of it, but maybe we should just rename it to "Gears"?

Additionally, as said a few months ago, we can remove the message "Turbo is not available for your browser.", which is just kind of left there without a header or any explanation of what "Turbo" is.

I say we clean this up then close this ticket out, and open a new ticket when browsers begin to drop Gears.

comment:14 Denis-de-Bernardy4 years ago

patch needs a refresh

comment:15 nacin4 years ago

(In [13833]) Remove 'Turbo' link from admin header. see #11301

comment:16 ocean904 years ago

Here is a fix for the javascript function for checking if gears is installed. Problem is, that gears is not always initialized.

http://wordpress.pastebin.com/sRrPxANb

(if someone needs it, in r13833 the link is removed.)

comment:17 nacin4 years ago

(In [13834]) Update string to better reflect the times. see #11301

comment:18 ryan4 years ago

We have the all clear to remove gears completely. Let's leave the manifest stuff as is but remove the JS and everything from the UI.

comment:19 nacin4 years ago

  • Type changed from enhancement to task (blessed)

rmccue4 years ago

Remove Gears stuff from tools.php

rmccue4 years ago

Remove Gears JS files and entry in script-loader

comment:20 rmccue4 years ago

  • Keywords has-patch added

comment:21 nacin4 years ago

(In [13981]) Remove Gears from UI. see #11301

comment:22 follow-up: nacin4 years ago

The tools menu is now empty for those with the read capability. I'd bump it to edit_posts right now, but someone could be using the tool_box action to add stuff for readers.

Personally, I don't like the idea of shipping an empty tools menu to subscribers in a default install. As it is, I always wondered why gears wasn't edit_posts to begin with.

comment:23 in reply to: ↑ 22 scribu4 years ago

Replying to nacin:

The tools menu is now empty for those with the read capability. I'd bump it to edit_posts right now, but someone could be using the tool_box action to add stuff for readers.

+1 on bumping to edit_posts. Tools should mean "tools for creating/managing content".

comment:24 nacin4 years ago

(In [14097]) Bump tools.php from read cap to edit_posts. Old cap was for Gears. fixes #12903, see #11301.

comment:25 nacin4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

comment:26 solarissmoke4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

One more file to remove: wp-admin/gears-manifest.php

comment:27 dd324 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I believe the Manifest is staying for users who've currently got Gears active. see ryans comment above mentioning leaving the manifest too

comment:28 nacin4 years ago

Yes, we're leaving the manifest for now.

Note: See TracTickets for help on using tickets.