WordPress.org

Make WordPress Core

Opened 15 years ago

Closed 15 years ago

#1131 closed defect (bug) (fixed)

Rev 2455 of wp-includes/functions.php breaks the admin interface

Reported by: kim Owned by: matt
Milestone: Priority: normal
Severity: critical Version: 1.5.1
Component: Administration Keywords:
Focuses: Cc:

Description

Since the WP_INSTALLING constant is not defined during normal operation, calling constant('WP_INSTALLING') causes an error about the constant not existing. This is printed many times over when entering the dashboard.

Looking at the code, I think calling defined('WP_INSTALLING') achieves what was intended.

Patch attached.

Attachments (1)

functions.diff (548 bytes) - added by kim 15 years ago.

Download all attachments as: .zip

Change History (4)

#1 @kim
15 years ago

  • Patch set to No

#2 @kim
15 years ago

I have error_reporting=E_ALL and display_errors=On, and the error messages are what breaks the admin interface.

#3 @matt
15 years ago

  • fixed_in_version set to 1.5.1
  • Owner changed from anonymous to matt
  • Resolution changed from 10 to 20
  • Status changed from new to closed

@kim
15 years ago

Note: See TracTickets for help on using tickets.