WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 4 years ago

#11319 closed enhancement (duplicate)

oEmbed should be integrated into Add ... from URL experiences

Reported by: lloydbudd Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Editor Keywords: needs-patch
Focuses: Cc:

Description (last modified by lloydbudd)

oEmbed should be integrated into Add ... from URL experiences

enhancement, ENV: WP 2.9-beta-2 ++ (trunk r12320)

For WP 2.9 we removed oEmbed from the UI, #11288.

The "Embed" field did not validate the oEmbed, that is part of the reason I recommended not incorporating UI for WP 2.9 -- I think JS based validation is essential to a good experience.

If you use the "Insert an image from another web site", once you input a URL, WordPress should automatically check if it is an oEmbed link and adjust and populate the fields as appropriate.

ADDITIONAL DETAILS

If JS is disabled, I see little benefit to including a oEmbed form. The ability just to include oEmbeds on their own line in the content seems like a good balance.

Change History (5)

#1 @nacin
8 years ago

  • Milestone changed from 3.0 to 3.1

Sounds good for 3.1.

#2 @sean212
8 years ago

  • Keywords needs-patch added

#3 @lloydbudd
8 years ago

  • Description modified (diff)

#4 @nacin
8 years ago

  • Milestone changed from Awaiting Triage to Future Release

#5 @johnbillion
4 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22548.

Note: See TracTickets for help on using tickets.