WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#11350 closed defect (bug) (fixed)

Post tags (wp-admin/edit-tags.php) doesn't work without JavaScript

Reported by: holizz Owned by:
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.9
Component: Accessibility Keywords: has-patch
Focuses: Cc:

Description

Given JavaScript is disabled
And I am on the post tags page
Then I fill in "Tag name" with "testing"
And I press "Add Tag"
Then I should see "testing" within the table of tags

Attachments (2)

11350-edit-tags-no-JS.diff (274 bytes) - added by nacin 11 years ago.
Fix.
11350-edit-tags-no-JS.2.diff (553 bytes) - added by nacin 11 years ago.
Fix typo.

Download all attachments as: .zip

Change History (11)

#1 @dd32
11 years ago

  • Component changed from General to UI
  • Keywords needs-patch added
  • Milestone changed from Unassigned to 2.9
  • Version set to 2.9

Current "correct" behaviour would be for the add tags button to be hidden.

Current expected behaviour is that multiple tags would be seperated with commas within the tags field if JS was unavailable.

(AFAIK)

#2 @janeforshort
11 years ago

  • Component changed from UI to Accessibility

There should be a non-JS version that triggers a screen refresh when you click the Add Tag button. I just disabled JS on OSX/FF3 to see what happens, and it refreshed the screen on submit but didn't add the new tag to the table. Definitely a bug. Changing component to accessibility because having non-JS methods of performing tasks is an accessibility requirement.

#3 @markjaquith
11 years ago

  • Milestone changed from 2.9 to 3.0

This bug is important to us, but as it isn't the only way to add tags (it's a rather untraditional method), we're not going to hold up the release for it. Can someone step up to tackle this for early 3.0?

@nacin
11 years ago

Fix typo.

#4 @nacin
11 years ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from 3.0 to 2.9

Meant to replace first patch with second.

Easy fix, it was a typo from #10239. That ticket is from the 2.9 dev cycle, which makes this a regression.

#5 @azaozz
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [12442]) Fix typo in edit-tags.php, props nacin, fixes #11350 for trunk

#6 @azaozz
11 years ago

(In [12443]) Fix typo in edit-tags.php, props nacin, fixes #11350 for 2.9

#7 @azaozz
11 years ago

(In [12444]) Fix typo in edit-tags.php (proper patch), props nacin, fixes #11350 for trunk

#8 @azaozz
11 years ago

(In [12445]) Fix typo in edit-tags.php (proper patch), props nacin, fixes #11350 for 2.9

#9 @azaozz
11 years ago

First patch is the right one...

Note: See TracTickets for help on using tickets.