WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 6 years ago

Last modified 6 years ago

#11365 closed defect (bug) (fixed)

press-this.php resize could be a little taller

Reported by: netweblogic Owned by: azaozz
Milestone: 3.8 Priority: low
Severity: trivial Version: 2.8.5
Component: Press This Keywords:
Focuses: ui Cc:

Description

The press this pop-out window ends up having a scroll bar (Tested on Opera, FF and Chrome) because the window height is slightly too small.

I found that changing /wp-admin/press-this.php line 422 to :

window.resizeTo(720,600);

Solves the problem.

Attachments (1)

11365.patch (491 bytes) - added by Utkarsh 11 years ago.

Download all attachments as: .zip

Change History (10)

#1 @azaozz
11 years ago

  • Milestone changed from 2.9 to 3.0

@Utkarsh
11 years ago

#2 @scribu
11 years ago

  • Component changed from General to Press This
  • Keywords has-patch added; press this removed
  • Owner set to noel

#3 @Utkarsh
11 years ago

  • Cc admin@… added

#4 @hakre
11 years ago

Was able to reproduce but it came to my attention that this does not happen all the times. This is most importantly related to a user setting, the height of the visual editor. It can be resized, If I make is smaller it fits into the default window and the patch woldn't be necessary.

Therefore I suggest the patch takes the actual size of the visual editor into account and not set the height to a fixed default height. What do you think Utkarsh?

#5 @dd32
11 years ago

Having a long category list will also cause the scrollbars to appear.

#6 @dd32
11 years ago

  • Type changed from enhancement to defect (bug)

changing to defect, as the entire functionality is not always shown due to window size.

#7 @nacin
11 years ago

  • Milestone changed from 3.0 to Future Release
  • Owner changed from noel to azaozz
  • Priority changed from normal to low
  • Status changed from new to assigned

TinyMCE uses its most recent height also in press this (stored in a cookie), and that's why you're sometimes getting scrollbars. We'd need to retrieve it and properly calculate what the height of the window should be.

Moving to future, lowering the priority, assigning to azaozz for when he returns.

#8 @chriscct7
6 years ago

  • Focuses ui added
  • Keywords needs-refresh close added; has-patch removed
  • Resolution set to duplicate
  • Status changed from assigned to closed

This was solved in the changeset for issue #26508

#9 @DrewAPicture
6 years ago

  • Keywords needs-refresh close removed
  • Milestone changed from Future Release to 3.8
  • Resolution changed from duplicate to fixed

Fixed in [26836], see #26508.

Note: See TracTickets for help on using tickets.