WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11368 closed defect (bug) (worksforme)

RSS Full text shows caption code, summary text does not show caption code

Reported by: xwindowuser Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.5
Component: Feeds Keywords: reporter-feedback dev-feedback
Focuses: Cc:

Description

When I set my RSS settings to full text, the feed goes out with the caption code embedded in the post. when I change it to summary text the caption code is cleaned out. I have had readers point this out to me and I have figured it out and it comes down to having to turn full text off and only use summary text.
Is there a fix for this? thanks.
Example:

[caption id="attachment_877" align="alignleft" width="150" caption="Some Picture"][/caption]


The above code is included when feed is set to full text. Any help would be much appreciated.
thanks.

Change History (22)

comment:1 follow-up: nacin4 years ago

Can you try disabling all plugins? It sounds like one of them is mucking with do_shortcode.

comment:2 scribu4 years ago

  • Keywords reporter-feedback added; RSS Caption Code removed

comment:3 in reply to: ↑ 1 xwindowuser4 years ago

Replying to nacin:

Ok disabled all plugins completely. Still doing it. Turn on Summary and it doesn't do the code problem, Turn on Full text it does insert code into rss post.

Is anyone else having this problem?

[caption id="attachment_394" align="alignleft" width="70" caption="test question"][/caption] rss is messing up, testing. 

comment:4 nacin4 years ago

Based on quick testing when I first saw this ticket, the [caption] shortcode seems to expect content, else it hiccups. Is your post actually [caption ...]caption or is there something inside the opening and closing shortcode?

comment:5 xwindowuser4 years ago

Well here is an example :
[caption id="attachment_394" align="alignleft" width="70" caption="Question Authority"]caption

This is the caption: caption="Question Authority"

those are the words under the little picture inserted into the post. as for inside the opening and closing shortcode no there is nothing, I am not sure there is a place to do that????
again, this ONLY happens when I turn on full text.
Thansk for working with me on this.

comment:6 xwindowuser4 years ago

Here's another Thing I noticed, when I take the caption out from under the little picture the code disappears.
However this looks ugly as theres not border around the picture.

comment:7 xwindowuser4 years ago

Well here is an example : [caption id="attachment_394" align="alignleft" width="70" caption="Question Authority"]/caption

This is the caption: caption="Question Authority"

those are the words under the little picture inserted into the post. as for inside the opening and closing shortcode no there is nothing, I am not sure there is a place to do that???? again, this ONLY happens when I turn on full text.
Here's another Thing I noticed, when I take the caption out from under the little picture the code disappears. However this looks ugly as there's not border around the picture.

Thanks for working with me on this.

comment:8 follow-up: hakre4 years ago

I think you made yourself pretty clear. Please verify wether you have an excerpt for that post or it is automatically generated.

Additionally I would tend to say that shortcodes aren't supported in excerpts. So this is not a bug but the normal behavior.

comment:9 in reply to: ↑ 8 ; follow-up: xwindowuser4 years ago

Replying to hakre:

I think you made yourself pretty clear. Please verify wether you have an excerpt for that post or it is automatically generated.

Additionally I would tend to say that shortcodes aren't supported in excerpts. So this is not a bug but the normal behavior.

I guess I am unsure as to what you mean for an excerpt. The code only shows when I have turned on full text in settings>reading>full text. When I turn it to summary it doesn't do it.
I would like to be able to turn on full text for my feeds and not have the code show.
Thanks again.

comment:10 in reply to: ↑ 9 xwindowuser4 years ago

Replying to xwindowuser:

Replying to hakre:

I think you made yourself pretty clear. Please verify wether you have an excerpt for that post or it is automatically generated.

Additionally I would tend to say that shortcodes aren't supported in excerpts. So this is not a bug but the normal behavior.

I guess I am unsure as to what you mean for an excerpt. The code only shows when I have turned on full text in settings>reading>full text. When I turn it to summary it doesn't do it.
I would like to be able to turn on full text for my feeds and not have the code show.
Thanks again.

here is an excerpt from a full text feed from a recent post:

“You Paid $21 for Only Three Pieces of Produce?!”

Posted:

When Buying Organic Is Too Expensive I normally do the grocery shopping when it comes to produce. But the other day, my other half did the honors. And I was very thankful that he did. He brought home some really nice fruit and vegetables. However, some of his choices caught my ...
Homemade Baby Food: Easy, Economical and Healthy

Posted:

[caption id="attachment_186" align="alignleft" width="267" caption="Baby Food Cubes"][/caption] Since I now have a child, I think I am turning into the "food police" (not that I wasn't already).  Because I am "in the know" of what is in our food and water supply, I am very vigilant on taking steps to reduce ... 

the caption under teh images is: caption="Baby Food Cubes"

comment:12 scribu4 years ago

Try upgrading to WP 2.9 and see if the problem goes away.

comment:13 hakre4 years ago

Just tested against current trunk:

  1. RSS Full text: does not show any caption code nor does it show a caption or an image.
  2. RSS Summary: does not show any caption code nor does it show a caption or an image.

Taken the original report description into account, I can not reproduced. Based on the point of view this can mean that a) it is resolved or b) it has evolved and now spreads over both feeds.

So the questions I ask are:

  1. How should images be reflected in feeds?
  2. How should image based shortcodes be reflected in feeds?

HTML source of my testcase for the post is:

[caption id="attachment_74" align="alignnone" width="300" caption="Red racing car"]<a href="http://192.168.2.106/wordpress-trunk/wp-content/uploads/Auto-na-dálkové-ovládání.jpg"><img class="size-medium wp-image-74" title="Auto na dálkové ovládání" src="http://192.168.2.106/wordpress-trunk/wp-content/uploads/Auto-na-dálkové-ovládání-300x208.jpg" alt="" width="300" height="208" /></a>[/caption]

Your's might differ.

comment:14 hakre4 years ago

  • Keywords dev-feedback added

comment:15 nacin4 years ago

hmm, I think the issue is that the caption shortcode (all shortcodes?) chokes when it has no internal content [caption blah blah]caption. I think I was able to somewhat reproduce his report when I did that.

That isn't really a valid use of the shortcode, though.

comment:16 xwindowuser4 years ago

ok here is what I get. BTW I upgraded to 2.9 and now the full text setting gives me summary posts in my email.

ok so when I create a post, I do my writing then I go up top and click on "add an image".
It pulls up the add an image dialog box in which I choose an image either from my computer or in the media gallery. In the caption area I enter a caption. then I clcik icon and then click insert.
That is how I insert a little image at the beginning of my articles.

It is also how I insert images into my articles. and that is how I get caption or shortcode in my posts when it is on full text mode of RSS.

When I would change it to summary I wouldn't get that problem.

Now that I have upgraded, I have the setting in read set to full text and all I get are summaries or excerpts in my RSS to email via feedburner.

I am either confused or something is not right.

so in the settings of my blog, in "read" I have "For each article in a feed, show " Full Text. and all I now get is Sumary, with no shortcode in it. or images.

comment:17 xwindowuser4 years ago

@Niacin See above also all my captions have captions:

[caption id="attachment_186" align="alignleft" width="267" caption="Baby Food Cubes"][/caption]

comment:18 xwindowuser4 years ago

Can I just give one of you guys my login info and have you look at it, instead of me trying to convey what I am seeing?
email me at darkman@…
thanks.

comment:19 xwindowuser4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I found this on the feedburner forum. when I changed my feed input on feedburner from this:
http://www.darkmansdarkroom.com/feed/rss
to this:
http://www.darkmansdarkroom.com/feed/rss2

everything worked.
I also changed the link that was in my template from this:
http://www.darkmansdarkroom.com/feed/rss
to this
http://www.darkmansdarkroom.com/feed/rss2
and it now gives a correct full text feed.

thanks for the help guys.

comment:20 nacin4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:21 nacin4 years ago

  • Milestone Unassigned deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:22 nacin4 years ago

  • Component changed from General to Feeds
Note: See TracTickets for help on using tickets.