Make WordPress Core

Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#1144 closed defect (bug) (duplicate)

REQUEST_URI may be encoded but PATH_INFO, get_option('home') are not

Reported by: lev Owned by: ryan
Milestone: Priority: normal
Severity: major Version: 1.5
Component: General Keywords: has-patch needs-testing
Focuses: Cc:


Say someone is using unix style home directories in the blog url, like http://www.example.com/~frank is the blog home page.

1.) Telnet into example.com port 80.
2.) Type in the http request "GET /~frank/ HTTP/1.0", hit enter twice after typing that in.
3.) The resulting web page that comes out on the screen has the navigation link to get to the next page look like "http://example.com/~frank/page/2/". This is fine.

4.) However, telnet back into example.com port 80.
5.) Type in this http request, "GET /%7Efrank/ HTTP/1.0", then hit enter twice.
6.) The resulting web page has a navigation link to get to the next page that looks like "http://example.com/~frank/%7Efrank/page/2/". This is a problem.

Attachments (1)

1144.diff (480 bytes) - added by mdawaffe 9 years ago.
urldecode request_uri?

Download all attachments as: .zip

Change History (8)

comment:1 @lev11 years ago

  • Patch set to No

@mdawaffe9 years ago

urldecode request_uri?

comment:2 @mdawaffe9 years ago

  • Owner changed from anonymous to ryan
  • Summary changed from Web page links generated by posts_nav_link depends upon encoding of tilde in http request. to REQUEST_URI may be encoded but PATH_INFO, get_option('home') are not

comment:3 @Nazgul9 years ago

  • Keywords has-patch added
  • Milestone set to 2.1

comment:4 @matt9 years ago

  • Milestone changed from 2.1 to 2.2

comment:5 @foolswisdom9 years ago

In #3727 Kirin_Lin did a fantastic job of describing another symptom caused by this problems and suggesting the same patch
ENV: WP 2.1

comment:6 @rob1n9 years ago

  • Keywords needs-testing added
  • Resolution set to duplicate
  • Status changed from new to closed

After asking rboren, I'm closing this one as duplicate as #3727 is the same issue, and it has a current patch.

comment:7 @rob1n9 years ago

  • Milestone 2.2 deleted
Note: See TracTickets for help on using tickets.