WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#11467 closed defect (bug) (worksforme)

Random addition of categories to Posts when saving

Reported by: markhowellsmead Owned by:
Milestone: Priority: normal
Severity: major Version: 2.8.5
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

When I create a new article (which WordPress calls a “post”), I assign it to a category using a list I defined when setting up the site. The problem comes when re-editing the post: in many instances, the system then adds the post to another category at random when saving. I can only surmize that WordPress contains a bug when working with nested post categories, so that’s where my investigations will start.

I am using WP 2.8.5 on a standard English installation and the following active plugins.

  • Askimet
  • Duplicate Sidebar Widgets
  • Flexi Pages Widget
  • Google XML Sitemaps
  • Kimili Flash Embed
  • List Subpages
  • Markdown Extra
  • More Fields
  • PostMaster

Change History (13)

comment:1 scribu4 years ago

  • Keywords random bug removed

You should start your investigation using WP 2.9-RC1.

comment:2 scribu4 years ago

  • Milestone Unassigned deleted
  • Resolution set to invalid
  • Status changed from new to closed

Please reopen when you have exact steps to reproduce.

comment:3 markhowellsmead4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

The fact that it's a random occurrence means that it's not possible to identify "exact steps". I know becuse I've tried many times over the past few months trying to make it happen on purpose, and cannot.

comment:4 demetris4 years ago

  • Cc dkikizas@… added
  • Keywords category save removed

Possibly related, from the WP.org forum:

http://wordpress.org/support/topic/279509

@markhowellsmead: Have you tried disabling a few plugins to see if the problem persists? I know it’s not always feasible to do that in a live site, but, if you can, maybe it would help. (Maybe starting from the ones that seem related to posting, like More Fields and PostMaster.)

comment:5 markhowellsmead4 years ago

That cross-linked issue certainly seems to be the same problem. I've already tried raising the issue on the wordpress.org forums and my own website, but have received no responses over the past few weeks. I've encountered the same problem when no plugins are active, on a clean install, so the problem seems to be inherent to pre-2.9 releases.

comment:6 scribu4 years ago

  • Keywords reporter-feedback added
  • Milestone set to Unassigned

I've encountered the same problem when no plugins are active, on a clean install, so the problem seems to be inherent to pre-2.9 releases.

So did you try upgrading to WP 2.9?

comment:7 markhowellsmead4 years ago

Yes, but as that was yesterday and the problem is a random occurrence, I can't easily re-produce it.

comment:8 hakre4 years ago

Can you please try with a new, clean install and w/o plugins? The data of your blog might be corrupt and a new install with a fresh database might not produce that. This will also help to create a test-case where what you say is better to reproduce for others because they can follow these steps (new blog, that content etc.).

comment:9 hakre4 years ago

Can you provide a list of category names you're using on your site?

comment:10 markhowellsmead4 years ago

Advertising
Books
By other people
Design
Friends and family
From the Road
Gallery

  • Documentary galleries
  • England galleries
  • Event galleries
  • Individual photographs
  • Italy galleries
  • Portraiture galleries
  • Scotland galleries
  • Switzerland Galleries
  • Wales Galleries

Geek stuff
History
In the Media
Internet
Music
Photography
Prints for sale
Technique
Travek
Video
Work
Writing

comment:11 markhowellsmead4 years ago

Advertising
Books
By other people
Design
Friends and family
From the Road
Gallery

  • Documentary galleries
  • England galleries
  • Event galleries
  • Individual photographs
  • Italy galleries
  • Portraiture galleries
  • Scotland galleries
  • Switzerland Galleries
  • Wales Galleries

Geek stuff
History
In the Media
Internet
Music
Photography
Prints for sale
Technique
Travel
Video
Work
Writing

comment:12 nacin4 years ago

I'll be honest, I've seen this before, a long while ago, but I'm not sure if it's still present.

comment:13 nacin4 years ago

  • Milestone Unassigned deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

worksforme, pending new reports that this can be reproduced.

Note: See TracTickets for help on using tickets.