WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11492 closed defect (bug) (fixed)

Lack of escaping in _wp_comment_row()

Reported by: Denis-de-Bernardy Owned by:
Milestone: 2.9.1 Priority: normal
Severity: normal Version: 2.9
Component: Administration Keywords: has-patch tested
Focuses: Cc:

Description

The patch is originally based on this patch for #10182.

Attachments (1)

11492.diff (7.6 KB) - added by Denis-de-Bernardy 6 years ago.
completely untested

Download all attachments as: .zip

Change History (4)

@Denis-de-Bernardy6 years ago

completely untested

comment:1 @hakre6 years ago

  • Keywords tested added

Tested. Patch applies clean. Output is (more) fixed. There is an empty TBODY element (by design) and duplicate IDs (the standard problems we have). So therefore looks good to me.

comment:2 @ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [12493]) Add escaping to _wp_comment_row(). Props Denis-de-Bernardy. fixes #11492 for trunk

comment:3 @ryan6 years ago

(In [12494]) Add escaping to _wp_comment_row(). Props Denis-de-Bernardy. fixes #11492 for 2.9

Note: See TracTickets for help on using tickets.