WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#11496 closed defect (bug) (worksforme)

Error in moving to trash...

Reported by: justatest47 Owned by: Error in moving to trash...
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Trash Keywords: reporter-feedback
Focuses: Cc:

Description

Greetings I have just updated to 2.9 and now I am astonished and shocked to see that Wordpress instead of progressing is regressing... :O
Why in the world did you guys removed the "DELETE" option from Posts? Why does an article has to be firstly "Moved To Thrash" and only after-wards can be deleted??????????????????????????????????

Not only that this new feature is fully absurd but it's BUGGY too. If I try to move my DRAFTS into Thrash I get this: "Error in moving to trash..."

Please release 2.9.1 and add the Delete feature back or I think I will have to downgrade back to 2.8.6.
I am 100% sure that there are many other people like me! Many hate this new option. Please consider our opinions and don't ignore them. Don't forget that through our opinions Wordpress has got this far.

Just add these options: "Delete Permanently, Move to Thrash, Bulk Actions and Edit" so that posts can be deleted permanently without the need of moving them to thrash. Those who want to move them to thrash, fine, they have the "move to thrash" option. I don't disagree with that option because I'm sure it is useful to some people. It's just like in Windows. You select a file and press the delete key. It will move it to Recycle Bin but don't forget that Microsoft also LEFT this option for experts of permanently deleting files without the need of fist moving them to Recycle Bin by pressing the SHIFT + DELETE keys in the same time.

It's way more logical that way and I hope you agree with me because I'm right.

Attachments (1)

Bug.jpg (12.0 KB) - added by justatest47 4 years ago.

Download all attachments as: .zip

Change History (13)

justatest474 years ago

comment:1 dd324 years ago

You may add define('EMPTY_TRASH_DAYS', 0); to your wp-config.php file to remove the Trash feature, Items will be deleted straight away.

As for the regressing comment, That varies between people. Many would be lost without their Recycle bin on windows, The same applies to WordPress, Whilst many people live without it, its a good extra for many people - theres a reason why its been requested often.

I'll have a look into the Drafts vs. Trash and see if i can reproduce it.

comment:2 follow-up: dd324 years ago

Trashing Draft posts seems to work fine for me.

Thats by:

  1. Add new post, Add title and body, wait for autosave, Hit trash post.
  2. Add new post, add title and body, manually save. Go back to Edit posts list, hit trash post on the draft.

Can you try disabling all plugins and trying again?

Can you provide a step-by-step way to reproduce the error?

Thanks for reporting your difficulties.

comment:3 scribu4 years ago

  • Keywords reporter-feedback added; Error in moving to trash... removed

comment:4 westi4 years ago

  • Priority changed from highest omg bbq to normal
  • Severity changed from critical to normal

Reducing priority and severity as the functionality has been shown to work by other users - I have also tested this myself and it works fine for me too.

As detailed above if you do not want the Trash feature you can easily disable it from wp-config.php.

comment:5 caesarsgrunt4 years ago

  • Cc caesar@… added
  • Component changed from Administration to Trash

comment:6 hakre4 years ago

A sidenote: After everything is in trash, a single button click can empty the trash. Even though a user needs to adopt the new concept, it's not that bad to manage the changes IMHO.

comment:7 in reply to: ↑ 2 ; follow-up: bingorabbit4 years ago

  • Cc bingorabbit@… added

Replying to dd32:

Trashing Draft posts seems to work fine for me.

Thats by:

  1. Add new post, Add title and body, wait for autosave, Hit trash post.
  2. Add new post, add title and body, manually save. Go back to Edit posts list, hit trash post on the draft.

Can you try disabling all plugins and trying again?

Can you provide a step-by-step way to reproduce the error?

Thanks for reporting your difficulties.

+1 for this, I tried reproducing the error but fortunately everything went just fine.

I think adding Delete Permanently option will solve this conflict, the same as Shift+Delete thing, hence, it will be the user's responsibility for his decision.

comment:8 in reply to: ↑ 7 ; follow-up: caesarsgrunt4 years ago

Replying to bingorabbit:

I think adding Delete Permanently option will solve this conflict, the same as Shift+Delete thing, hence, it will be the user's responsibility for his decision.

Adding a Delete Permanently link as well as the Trash link would defeat the purpose of Trash to a large extent, since if you were to click Delete Permanently by mistake it could not be undone. Adding a shift-click functionality might be good, and I bought this up when developing the Trash feature, but the core devs didn't like the idea.

comment:9 westi4 years ago

  • Milestone 2.9.1 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I have done some more testing on this with and without Javascript disabled.

The only way I can see from a review of the code for you to get this message is if the post was already marked as Trash.

Then the code in wp_trash_post() will return false.

Closing as this works for me and other testers.

comment:10 in reply to: ↑ 8 ; follow-up: justatest474 years ago

Replying to caesarsgrunt:

Replying to bingorabbit:

I think adding Delete Permanently option will solve this conflict, the same as Shift+Delete thing, hence, it will be the user's responsibility for his decision.

Adding a Delete Permanently link as well as the Trash link would defeat the purpose of Trash to a large extent, since if you were to click Delete Permanently by mistake it could not be undone. Adding a shift-click functionality might be good, and I bought this up when developing the Trash feature, but the core devs didn't like the idea.

It won't defeat the purpose of the Thrash at all. It will actually improve it.
In Windows you have Delete = Move to Thrash and you also have SHITF + Delete = Permanently Delete.

Why not just rename the Thrash button into "Move to Thrash Can" and add next to it the button "Delete" or "Permanently Delete". People are not so retarded as some may think. There are advanced users out there who would disagree with this new limitation.
After all I'm the admin, I'm supposed to know what I'm doing on my blog, I'm not supposed to be a novice imbecile who accidentally presses "Delete" and not knowing what that button is doing.
So from what I'm understanding is that you are going to ignore my request and BUG. So I have to downgrade to 2.8.6 :(
Ohh well... thanks anyway....

comment:11 in reply to: ↑ 10 caesarsgrunt4 years ago

I didn't mean shift-click to delete permanently, like in Windows, was a bad idea; I meant re-introducing a straight delete button is a bad idea.

Nor am I suggesting that people don't know what delete means; rather that it is very easy to accidentally select the wrong comment to delete.

In answer to your comments about downgrading to remove the trash feature; there's absolutely no need to do that. Just add define('EMPTY_TRASH_DAYS', 0); to your wp-config.php file, and trash will be disabled.

Incidentally, trash and thrash mean two quite different things... :-p

comment:12 cCat55643 years ago

Same thing happens on WP 3.0.4

Note: See TracTickets for help on using tickets.