WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11525 closed defect (bug) (fixed)

Plugin Compatibility Fails to Consider Future RC Versions

Reported by: miqrogroove Owned by: westi
Milestone: 2.9.1 Priority: normal
Severity: minor Version: 2.9
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Now that 2.9 is out, anyone still running 2.9-RC is going to be confronted with something like this in the Upgrade screen:

qTranslate
You are running version 2.5. Upgrade to 2.5.3.
Compatibility with WordPress 2.9: 0% (0 "works" votes out of 4 total)
Compatibility with WordPress 2.9: 0% (0 "works" votes out of 4 total)

Yikes. That doesn't look right...

See http://core.trac.wordpress.org/browser/tags/2.9/wp-admin/update-core.php#L189

$compat = '<br />' . sprintf(__('Compatibility with WordPress ...

and http://core.trac.wordpress.org/browser/tags/2.9/wp-admin/update-core.php#L197

$compat .= '<br />' . sprintf(__('Compatibility with WordPress ...

Attachments (1)

11525.diff (739 bytes) - added by westi 4 years ago.
Don't display plugin compatibility info if the new WordPress version is the same as the current one. For example for RC/Beta upgrades.

Download all attachments as: .zip

Change History (9)

comment:1 westi4 years ago

  • Keywords reporter-feedback added

What is wrong here.

If you look at WordPress.org the compatibility for qTranslate currently says:

Broken :(
0 people say it works.
5 people say it's broken.

What were you expecting it to say?

It is not compatible with your current version of WordPress or the one available for upgrade too.

comment:2 westi4 years ago

  • Owner set to westi
  • Status changed from new to accepted

comment:3 dd324 years ago

What is wrong here.

Compatibility with WordPress 2.9: 0% (0 "works" votes out of 4 total)
Compatibility with WordPress 2.9: 0% (0 "works" votes out of 4 total)

Where, The first line is the Current version of WordPress, and the 2nd line is the Upgrade version. The result is 2 lines which look identical when Current === Upgrade version.

comment:4 westi4 years ago

  • Keywords reporter-feedback removed

Ok. So the nub of the issue is if the information returned by the Core Update API says that the latest version is a.b and you are running a pre-release version of a.b e.g. a.b-beta1 or a.b.-rc1 then you will see two messages.

The normal intention is to show compatibility with the current version versus compatibility with the version you are upgrading to.

For example if I hack my WordPress to think it is 2.8 even though it is 2.9 I see:

You are running version 2.5. Upgrade to 2.5.3.
Compatibility with WordPress 2.8: 100% (according to its author)
Compatibility with WordPress 2.9: 0% (0 "works" votes out of 6 total)

I will attach a patch which fixes this for me.

westi4 years ago

Don't display plugin compatibility info if the new WordPress version is the same as the current one. For example for RC/Beta upgrades.

comment:5 miqrogroove4 years ago

Looks good. Does this needed to be future-proofed against 'beta' or 'RC' sneaking into get_core_updates()->current ?

comment:6 ryan4 years ago

Only final releases will show in get_core_updates().

comment:7 ryan4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [12477]) Don't display plugin compatibility info if the new WordPress version is the same as the current one. For example for RC/Beta upgrades. Props westi. fixes #11525 for trunk

comment:8 ryan4 years ago

(In [12478]) Don't display plugin compatibility info if the new WordPress version is the same as the current one. For example for RC/Beta upgrades. Props westi. fixes #11525 for 2.9

Note: See TracTickets for help on using tickets.