WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11533 closed defect (bug) (duplicate)

Category management issue

Reported by: Alkorr Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Administration Keywords:
Focuses: Cc:

Description

Hi, I have several problems managing categories. I use these categories:

Books

  • Reviews

-- Fantasy

-- RPG

Videogames

  • Reviews

-- Fantasy

-- RPG

When I write a post, I only select the category Fantasy (in Books > Reviews) and the <?php the_category(' > ', 'multiple'); ?> function works perfectly and gives: Books > Reviews > Fantasy.

But when I go to the Edit Posts Page, there is the list of my posts and when I look at the Categories column, only 'Fantasy' appears. So I don't know if it's Fantasy from the Books main category, or Fantasy from the Games main category. I have to put my mouse on Fantasy and look at the status bar to finally find out what's the parent category. Not really useful when you use Wordpress as a CMS with multiple authors, managing posts becomes very difficult.

But it leads to another problem: when I open this post and look at the category list on the right, Fantasy is selected but it's not hierarchical at all, the selected cateogry appears on top of all others, so I have no idea what is the category parent: Books or Games? I have to go back to the Edit Posts Page, put my mouse on Fantasy and look at the status bar to finally find out what's the parent category. Again, it's very confusing when you manage authors and their posts...

The only way to have the full categories selected to appear on the Edit Posts Page and to be shown (hierarchically) when you open the post, is to select the parent category (Books), child (Reviews) and finally the last one (Fantasy). But then another problem arrives: the <?php the_category(); ?> function doesn't work anymore, displyaing all the categories: Books > Reviews Books > Fantasy Books > Review > Fantasy.

Totally weird!?!

Any logical explanation to this?

Any help is welcome, it must be bug.
Thank you!

Change History (2)

comment:1 scribu5 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This won't be a problem in WP 3.0, when you'll be able to create multiple category boxes.

See #10122

Marking as duplicate of #11510

comment:2 scribu5 years ago

Also, you might be interested in this plugin:

http://wordpress.org/extend/plugins/category-checklist-tree/

Note: See TracTickets for help on using tickets.