WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#11547 closed defect (bug) (duplicate)

Trouble with uploaded via Media Library files with non-latin characters in name

Reported by: ogonkov Owned by: hakre
Milestone: Priority: normal
Severity: normal Version: 2.9.1
Component: Charset Keywords:
Focuses: Cc:

Description

When you upload file with Russian name (as example), you got file with wrong encoding on server. Looks like file names just save as UTF8, but not converts to it.

Attachments (1)

wp-charset-media-library-bug.gif (29.5 KB) - added by ogonkov 6 years ago.
Example of wrong file names

Download all attachments as: .zip

Change History (14)

@ogonkov6 years ago

Example of wrong file names

comment:1 @ogonkov6 years ago

Trouble is since previous versions.

comment:2 @hakre6 years ago

  • Component changed from Media to Charset
  • Owner set to hakre

Which OS is the server running? Which encoding does the filename use, can you verify that?

How about the listing in the Media Library, are the files with wrong names there as well?

Reference: #9417

comment:3 @hakre6 years ago

  • Priority changed from low to high

comment:4 @hakre6 years ago

  • Milestone changed from Unassigned to 3.0

comment:5 follow-up: @ogonkov6 years ago

Server with this installation of WP is shared hosting, running on FreeBSD 6.2-RELEASE-p3 (this how it's showed on SSH connection). Don't sure what you mean under filename encoding, it's originally Cyrillic images, created on Win XP, so i think it's a CP1251. Also, i will use http://www.artlebedev.ru/tools/decoder/ to check filenames, and it's also shown that name are converted from CP1251 to UTF8.

In Media library file names listed correctly.
---
I will move my old WP install from old shared server to new VPS, thats when i spot this trouble.

On new server wrong filenames are OK now, only trouble i got is missed images thumbnails (and starnge filenames on server), but when i go to 'edit image' mode, image present smoothly. If i convert filename to proper on server, then WP didn't see it and got me 404 error.

I will add default UTF8 to my .htaccess (in the root of my site), to fix some other troubles with Cyrillic encoding in admin (inline edit of Entry link, for example, or popups with additional info of themes and plug-ins).

comment:6 in reply to: ↑ 5 @hakre6 years ago

  • Keywords media library utf-8 upload removed
  • Milestone 3.0 deleted
  • Priority changed from high to normal
  • Resolution set to invalid
  • Status changed from new to closed

Replying to ogonkov:

I will move my old WP install from old shared server to new VPS, thats when i spot this trouble.

From what you describe this is not a problem with wordpress. You're encounting a problem while moving from one system to another. Please get support in the forums for your problem, this is not a bug.

filename encoding: I mean the encoding filenames are stored within the filesystem. That's independend from WP, the Database or even the connection between your browser and the server (that is what you see in your browser then). Same for FTP/SSH connections.

comment:7 @ogonkov6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

You're encounting a problem while moving from one system to another.

I mean, that i spot trouble when move it, but trouble was on old server, before moving.

Sorry for my english, i will not any good on it.

comment:8 @Sparanoid6 years ago

  • Version changed from 2.9 to 2.9.1

This also happens in 3.0, no thumbnail image display in media library if files contain non-English characters. it generates a wrong url to the thumbnail image like:
%EF%BC%81.jpg-150x150.jpg

the actual thumbnail file generates on server is:
.jpg-150x150.jpg

comment:9 @ogonkov6 years ago

I think it's should be a different issue.

comment:10 @nacin5 years ago

  • Milestone set to 3.0

Setting to 3.0 for now.

If this is deemed invalid, it should be closed again as such.

comment:11 @bumbu5 years ago

  • Cc bmbalex@… added

problem with thumbnails seems to be the same as in this ticket http://core.trac.wordpress.org/ticket/11887

comment:12 @ryan5 years ago

  • Milestone changed from 3.0 to 3.1

comment:13 @nacin5 years ago

  • Milestone Awaiting Triage deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

#11887 closed as fixed.

Note: See TracTickets for help on using tickets.