WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 7 years ago

#1155 closed enhancement (duplicate)

Add wp-login.php to theme/template system

Reported by: TechGnome Owned by: markjaquith
Milestone: Priority: normal
Severity: normal Version: 2.0.1
Component: Template Keywords:
Focuses: Cc:

Description

Part of the new capability of WP 1.5.X is to only allow registered users to leave comments. Way cool. How ever, when they goto register, or login, they get the WP "standard" wp-login file. Stark white with the WP logo, etc.

What I think would be nice would be to have the ability to use custized verisons of this file in a template. This would allow it to loook more like it fits within the site. According to the Codex, just about everything else is theme-able.... but not this one. After consulting fellow WP'rs those who have solved this by hacking wp-login.php to make it look like the rest of their site. Which, is OK, but with the theme switcher on the loose, now, the login page looks out of place.

Bottom line, would it be possible to include wp-login.php as part of the theme/template possibilities?

Tg

Attachments (3)

wp-login Patch.patch (1.3 KB) - added by denney 8 years ago.
Patched WP-Login to support "template-based" login page.
wp-register Patch.patch (1.5 KB) - added by denney 8 years ago.
Patched WP-Register to support "template-based" register page.
login_hooks.patch (1.6 KB) - added by ryanscheuermann 8 years ago.
new hooks: login_head, login_pre, and login_post

Download all attachments as: .zip

Change History (14)

comment:1 TechGnome9 years ago

  • Patch set to No

comment:2 markjaquith8 years ago

  • Keywords bg|needs-patch added
  • Milestone set to 2.1
  • Owner changed from anonymous to markjaquith
  • Status changed from new to assigned
  • Version set to 2.0.1

+1

Matt has also expressed interest in this, IIRC

denney8 years ago

Patched WP-Login to support "template-based" login page.

denney8 years ago

Patched WP-Register to support "template-based" register page.

comment:3 denney8 years ago

The two patches I've submitted will look for "template-specific" login, register, lost password and register complete files and, if found, display them.

If they aren't found, the default WordPress pages will be displayed instead.

comment:4 masquerade8 years ago

As a whole, I love the idea of a themable login page, however.

We need to seriously consider the reprecussions of allowing the login page to be customized. One slip or missing piece of code, and we have a potentially compromised install. If we were to allow this, I think we need some high level forms of abstraction over the whole process, so that the theme developers never even see the source code made to verify logins and all.

As the patch stands, I am -1.

comment:5 skeltoac8 years ago

A single hook should suffice: login_head. You can do a lot with CSS.

For any greater demands, I would go as far as three hooks: login_head, login_pre and login_post. If the core markup is clean, there is nothing you can't do with a little CSS and surrounding markup.

I personally doubt worthiness of the concept, however. Themes are for presentation while the login screen is part of administration. Anything that changed my admin screens while calling itself a mere theme would quickly get the boot and a bad review.

comment:6 ryanscheuermann8 years ago

+1 for 3 hooks: login_head, login_pre, and login_post

CSS is your friend. :-)

I don't know about use in a theme, but a plugin like Tiger Admin (or any other admin stylesheet plugin) would definitely benefit from being able to make the Login screen consistent with the admin. I've done this using WP as a CMS for my clients.

But even so, styling it to be consistent with your theme (using the hooks) wouldn't be a bad idea when the Login screen is such an essential part to the public's view of the site.

Also, having a "login_pre" and "login_post" hook would allow people to include little messages like, "Remember, username is case sensitive." to the Login screen. Something my clients have needed a number of times...

ryanscheuermann8 years ago

new hooks: login_head, login_pre, and login_post

comment:7 ryanscheuermann8 years ago

I added a patch for the hooks, and I also moved some stray CSS to wp-admin.css. I don't know if this is my responsibility, but I needed it for my own personal reasons and figured uploading the patch wouldn't hurt.

Should similar hooks be considered for wp-register.php as well?

comment:8 rgovostes8 years ago

  • Keywords has-patch added

comment:9 foolswisdom8 years ago

treverturk commented that this might be an issue or the issue is changed now that ticket:3123 is fixed.

comment:10 matt7 years ago

  • Milestone changed from 2.1 to 2.2

comment:11 foolswisdom7 years ago

  • Keywords bg|needs-patch has-patch removed
  • Milestone 2.2 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Marking this a duplicate of #3123 which is fixed on trunk. If additional issues please open a new ticket based on current trunk.

Note: See TracTickets for help on using tickets.