WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 10 years ago

#11553 closed defect (bug) (duplicate)

"Recommendations" Should Be "Requirements"

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.0
Component: Upgrade/Install Keywords: commit
Focuses: Cc:

Description

The title <h1>System Recommendations</h1> in readme.html is ambiguous and should be changed.

http://core.trac.wordpress.org/browser/trunk/readme.html#L57

From Beasts at

http://wordpress.org/support/topic/342808?replies=2#post-1319345

Attachments (1)

11553.patch (1.2 KB) - added by hakre 11 years ago.

Download all attachments as: .zip

Change History (8)

#1 @nacin
11 years ago

In that case, a new recommendations section should be set up, with mod_rewrite (which would be new, but is listed elsewhere outside the readme) and a link to WordPress.org being the recommendations.

Or, we strip the 'link to wp.org' recommendation entirely. Point is we need to make sure that isn't under a "Requirements" header cause it isn't.

#2 @ryan
11 years ago

  • Milestone changed from 2.9.1 to 3.0

There's talk of removing readme.html in 3.0 since few people read it and it is oft neglected.

@hakre
11 years ago

#3 @hakre
11 years ago

as per http://wordpress.org/about/requirements/

I like to have a readme shipping in the package, but I'm okay with a textfile, it must noch be HTML.

#4 @dd32
11 years ago

  • Version set to 3.0

but I'm okay with a textfile, it must noch be HTML.

I dont see the harm in shipping a pretty document. WordPress is built upon Typography, so shipping a text document seems lazy.

Everyone who uses WordPress will have a Web Browser handy to view the document in.

#5 @Denis-de-Bernardy
11 years ago

  • Keywords commit added

#6 @dd32
10 years ago

Perhaps instead, This should be split into "System Requirements" and "System Recomendations" like most modern software does.

We require PHP 4.3, However, We could recomend PHP5 with the Date extension enabled for example.

I think We should make it clear that some features require later versions of PHP.

#7 @dd32
10 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as a duplicate of #10835 (Readme.html cleanups, rework) as it has a much larger overhaul and IMO, makes a better Requirement/Recomendations section.

Note: See TracTickets for help on using tickets.