WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11582 closed defect (bug) (fixed)

Code editor bug in Safari

Reported by: WraithKenny Owned by:
Milestone: 2.9.1 Priority: normal
Severity: normal Version: 2.9
Component: Editor Keywords: has-patch
Focuses: Cc:

Description

Rollover the Update button will cause the form div to clear the right hand list. Opening the WebKit Developer window and click on or off any CSS attribute will reset it. Probably a CSS issue, or maybe JavaScript. Hard to tell from Webkit's tool, firebug is better ;)

To reproduce, mouse over the update button again. Always reproducable on Safari 4 Win and Mac on WordPress 2.9

Attachments (1)

11582-theme-editor.diff (345 bytes) - added by nacin 4 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 nacin4 years ago

  • Milestone changed from Unassigned to 3.0

Confirmed in Chrome 3 and Safari 4. (I had actually click the button in Safari, though I'm running a beta build for that.)

Definitely JavaScript-related. Unable to reproduce in either browser with it disabled.

Also could not produce in 2.8.

Working to debug and patch now. Ideas appreciated. Setting to 3.0. Could go into a point release but we have to nail it first.

comment:2 nacin4 years ago

  • Keywords has-patch needs-review added
  • Milestone changed from 3.0 to 2.9.1

Got it. It's an unnecessary <br class="clear" />. To explain, this would clear the .fileedit-sub div, which doesn't need to be cleared. (Elements in the .fileedit-sub div do need to be cleared, and they are.) This troublesome piece of markup only exists in the theme editor; the plugin editor is spared.

Here's the interesting part -- I actually can't find where this piece of code was slipped in. It exists in 2.9 and trunk, but not 2.8. Couldn't find it in blame. I then looked through all changesets on this file since 2.8 and still couldn't find it. So if anyone can find when it was added, I'd love to see it.

This is definitely a 2.8 regression. Moving to 2.9.1. Please test -- with the patch, I confirm as fixed on both Chrome and Safari.

nacin4 years ago

comment:3 nacin4 years ago

  • Keywords needs-review removed

So:

This markup had been there for quite a while in both the theme and plugin editors. For #10101, the code was removed from the plugin editor in both the 2.8 branch (2.8.1 milestone) and trunk, but incidentally only removed from the plugin editor in 2.8, leaving it in trunk. For the changes to the 2.8 branch, see [11646]. Trunk: [11647].

comment:4 nacin4 years ago

Oops, should have said:

but incidentally only removed from the theme editor in 2.8, leaving it in trunk.

comment:5 ryan4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [12569]) Remove extraneous br. Props nacin. fixes #11582 for trunk

comment:6 ryan4 years ago

(In [12569]) Remove extraneous br. Props nacin. fixes #11582 for trunk

comment:7 ryan4 years ago

(In [12570]) Remove extraneous br. Props nacin. fixes #11582 for 2.9

Note: See TracTickets for help on using tickets.