Make WordPress Core

Opened 14 years ago

Closed 14 years ago

#11584 closed defect (bug) (invalid)

"Verify media file" faulty

Reported by: starcapt's profile StarCapt Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Media Keywords: reporter-feedback close
Focuses: Cc:

Description

When installing a media file, clicking on "Verify media file" can give false impression.

For example: Install "http://mysite/JoeDoaks.flv" Clicking "Verify" produces a "Success" result even though the actual name of the file is: "http://mysite/MP-JoeDoaks.flv"

The flash player will not play "http://mysite/JoeDoaks.flv" since it is not the true name of any installed file.

Attachments (1)

11584-test.flv (3 bytes) - added by hakre 14 years ago.
test flv file

Download all attachments as: .zip

Change History (5)

@hakre
14 years ago

test flv file

#1 @hakre
14 years ago

  • Keywords reporter-feedback added

I tried to reproduce what you reproted, but I was not able to because the problem description is too vague. Can you please provide detailed steps how to reproduce? I read "installing a media file" as uploading a media file but that did lead to nothing.

#2 @scribu
14 years ago

Maybe the problem was that "Verify media file" returned success on redirects?

#3 @dd32
14 years ago

  • Keywords close added

Where is this Verify Media functionality?

I cant find a similar string in trunk, and i cant find a reference to verification in Media Upload/select or TinyMCE's Flash editor.

In both cases, they accept 404 url's and do not attempt to check if its valid.

marking as close to find ticket again if someone cant come up with a location in core (I think it might be in a popular media plugin?)

#4 @nacin
14 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.