WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11591 closed defect (bug) (duplicate)

Translations need context when the string is integer value

Reported by: takayukister Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: I18N Keywords: has-patch tested
Focuses: Cc:

Description

On the translated version of WordPress, the gallery column drop-down menu is displayed incorrectly (I'll attach a screenshot). This may be caused because the translated string contains only integer value, and the string is used as an array key. Adding context to these translations can avoid this trouble.

Attachments (2)

broken-gallery-columns.png (42.1 KB) - added by takayukister 4 years ago.
Screenshot
media.php.diff (1.3 KB) - added by takayukister 4 years ago.
A patch

Download all attachments as: .zip

Change History (5)

takayukister4 years ago

Screenshot

takayukister4 years ago

A patch

comment:1 hakre4 years ago

  • Keywords has-patch tested added
  • Milestone changed from Unassigned to 3.0
  • Version set to 2.9

Was able to reproduce against current trunk, bug confirmed. Could reproduce with de_DE translation.

Patch still applies clean and fixes the issue.

Thanks for reporting this bug!

comment:2 nbachiyski4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11851

comment:3 nacin4 years ago

  • Milestone 3.0 deleted
Note: See TracTickets for help on using tickets.